11.2.1 Packet Tracer – Configure and Verify eBGP Answers

Last Updated on February 27, 2021 by Admin

11.2.1 Packet Tracer – Configure and Verify eBGP Answers

Packet Tracer – Configure and Verify eBGP (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Objectives

Configure and verify eBGP between two autonomous systems.

Background / Scenario

In this activity, you will configure and verify the operation of eBGP between autonomous systems 65001 and 65002. ACME Inc. is a company that has a partnership with Other Company and must exchange routes. Both companies have their own autonomous systems and will use ISP as the transit AS to reach each other.

Note: Only companies with very large networks can afford their own autonomous system.

Address Table

Device

Interface

IPv4 Address

Subnet Mask

Default Gateway

ACME1

G0/0

192.168.0.1

255.255.255.0

N/A

ACME1

S0/0/0

1.1.1.2

255.255.255.252

N/A

OtherCo1

G/0/0

172.16.10.1

255.255.255.0

N/A

OtherCo1

S0/0/0

1.1.1.10

255.255.255.252

N/A

ISP-Entry-1

S0/0/0

1.1.1.1

255.255.255.252

N/A

ISP-Entry-1

S0/0/1

1.1.1.5

255.255.255.252

N/A

ISP-Entry-2

S0/0/0

1.1.1.9

255.255.255.252

N/A

ISP-Entry-2

S0/0/1

1.1.1.6

255.255.255.252

N/A

PC0

NIC

DHCP

DHCP

192.168.0.1

Laptop0

NIC

DHCP

DHCP

192.168.0.1

Laptop1

NIC

DHCP

DHCP

192.168.0.1

Server

NIC

172.16.10.2

255.255.255.0

172.16.10.1

Instructions

Part 1:Configure eBGP in ACME Inc.

ACME Inc. hired an ISP to provide a connection to a partner company called Other Company. The ISP has established network reachability within its network and to Other Company. You must connect ACME to the ISP so that ACME and Other Company can communicate. Because the ISP is using BGP as the routing protocol, you must configure ACME1, which is the ACME border router, to establish a BGP neighbor connection with ISP-Entry-1. ISP-Entry-1 is the ISP border router that is directly connected to ACME.

  1. From ISP-Entry-1, verify that the ISP has provided IP reachability through its network by pinging 1.1.1.9, which is the IP address of the ISP-Entry-2 Serial 0/0/0 interface.
  2. From any device inside of the ACME network, ping the Other Company server at 172.16.10.2. The pings should fail because no BGP routing is configured at this time.
  3. Configure ACME1 to become an eBGP peer with ISP-Entry-1. ACME has AS number is 65001, and the ISP is using AS number 65003. Use 1.1.1.1 as the neighbor IP address and add the ACME internal network 192.168.0.0/24 to BGP.

ACME1(config)# router bgp 65001

ACME1(config-router)# neighbor 1.1.1.1 remote-as 65003

ACME1(config-router)# network 192.168.0.0 mask 255.255.255.0

From any device inside of the ACME network, ping the Other Company internal server again. Does it work?

Type your answers here.

No.

Part 2:Configure eBGP for Other Company Inc.

The network administrator at Other Company is not familiar with BGP and could not configure the Other Company side of the link. Because of this, you must also configure the Other Company end of the connection.

Configure router OtherCo1 to form an eBGP adjacency with ISP-Entry-2, which is the ISP border router facing OtherCo1. Other Company is under AS 65002 while ISP is under AS 65003. Use the 1.1.1.9 as the neighbor IP address of ISP-Entry-2 and add the Other Company internal network 172.16.10.0/24 to BGP.

OtherCo1(config)# router bgp 65002

OtherCo1(config-router)# neighbor 1.1.1.9 remote-as 65003

OtherCo1(config-router)# network 172.16.10.0 mask 255.255.255.0

Part 3:eBGP Verification

  1. Verify that ACME1 has formed an eBGP adjacency with ISP-Entry-1. The show ip bgp summary command is very useful here.
  2. Use the show ip bgp summary command to verify the routes that ACME1 has learned via eBGP and their status.
  3. Look at the routing tables on ACME1 and OtherCo1. ACME1 should have learned the route to the Other Company network 172.16.10.0/24. Similarly, OtherCo1 should now know about the route to the ACME network 192.168.0.0/24.
  4. Open a web browser in any ACME Inc. end device and navigate to the Other Company server by entering its IP address of 172.16.10.2
  5. From any ACME Inc. device, ping the Other Company server at 172.16.10.2.

End of document

Scripts

ACME1 Configuration

router bgp 65001

neighbor 1.1.1.1 remote-as 65003

network 192.168.0.0 mask 255.255.255.0

OtherCo1 Configuration

router bgp 65002

neighbor 1.1.1.9 remote-as 65003

network 172.16.10.0 mask 255.255.255.0

 

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments