14.9.11 Packet Tracer – Layer 2 VLAN Security Answers

Packet Tracer – Layer 2 VLAN Security (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Objectives

Connect a new redundant link between switches.

Enable trunking and configure security on the new trunk link between switches.

Create a new management VLAN and attach a management PC to that VLAN.

Implement an ACL to prevent outside users from accessing the management VLAN.

Background / Scenario

A company’s network is currently set up using two separate VLANs: VLAN 5 and VLAN 10. In addition, all trunk ports are configured with native VLAN 15. A network administrator wants to add a redundant link between switch SW-1 and SW-2. The link must have trunking enabled and all security requirements should be in place.

In addition, the network administrator wants to connect a management PC to switch SW-A. The administrator would like to enable the management PC to connect to all switches and the router but does not want any other devices to connect to the management PC or the switches. The administrator would like to create a new VLAN 20 for management purposes.

All devices have been preconfigured with:

  • Enable secret password: ciscoenpa55
  • Console password: ciscoconpa55
  • SSH username and password: SSHadmin / ciscosshpa55

Instructions

Part 1:Verify Connectivity

Step 1:Verify connectivity between C2 (VLAN 10) and C3 (VLAN 10).

Step 2:Verify connectivity between C2 (VLAN 10) and D1 (VLAN 5).

Note: If using the simple PDU GUI packet, be sure to ping twice to allow for ARP.

Part 2:Create a Redundant Link Between SW-1 and SW-2

Step 1:Connect SW-1 and SW-2.

Using a crossover cable, connect port F0/23 on SW-1 to port F0/23 on SW-2.

Step 2:Enable trunking, including all trunk security mechanisms on the link between SW-1 and SW-2.

Trunking has already been configured on all pre-existing trunk interfaces. The new link must be configured for trunking, including all trunk security mechanisms. On both SW-1 and SW-2, set the port to trunk, assign native VLAN 15 to the trunk port, and disable auto-negotiation.

SW-1(config)# interface f0/23

SW-1(config-if)# switchport mode trunk

SW-1(config-if)# switchport trunk native vlan 15

SW-1(config-if)# switchport nonegotiate

SW-1(config-if)# no shutdown

SW-2(config)# interface f0/23

SW-2(config-if)# switchport mode trunk

SW-2(config-if)# switchport trunk native vlan 15

SW-2(config-if)# switchport nonegotiate

SW-2(config-if)# no shutdown

Part 3:Enable VLAN 20 as a Management VLAN

The network administrator wants to access all switch and routing devices using a management PC. For security purposes, the administrator wants to ensure that all managed devices are on a separate VLAN.

Step 1:Enable a management VLAN (VLAN 20) on SW-A.

  1. Enable VLAN 20 on SW-A.

SW-A(config)# vlan 20

SW-A(config-vlan)# exit

  1. Create an interface VLAN 20 and assign an IP address within the 192.168.20.0/24 network.

SW-A(config)# interface vlan 20

SW-A(config-if)# ip address 192.168.20.1 255.255.255.0

Step 2:Enable the same management VLAN on all other switches.

  1. Create the management VLAN on all switches: SW-B, SW-1, SW-2, and Central.

SW-B(config)# vlan 20

SW-B(config-vlan)# exit

SW-1(config)# vlan 20

SW-1(config-vlan)# exit

SW-2(config)# vlan 20

SW-2(config-vlan)# exit

Central(config)# vlan 20

Central(config-vlan)# exit

  1. Create an interface VLAN 20 on all switches and assign an IP address within the 192.168.20.0/24 network.

SW-B(config)# interface vlan 20

SW-B(config-if)# ip address 192.168.20.2 255.255.255.0

SW-1(config)# interface vlan 20

SW-1(config-if)# ip address 192.168.20.3 255.255.255.0

SW-2(config)# interface vlan 20

SW-2(config-if)# ip address 192.168.20.4 255.255.255.0

Central(config)# interface vlan 20

Central(config-if)# ip address 192.168.20.5 255.255.255.0

Step 3:Connect and configure the management PC.

Connect the management PC to SW-A port F0/1 and ensure that it is assigned an available IP address within the 192.168.20.0/24 network.

Step 4:On SW-A, ensure the management PC is part of VLAN 20.

Interface F0/1 must be part of VLAN 20.

SW-A(config)# interface f0/1

SW-A(config-if)# switchport access vlan 20

SW-A(config-if)# no shutdown

Step 5:Verify connectivity of the management PC to all switches.

The management PC should be able to ping SW-A, SW-B, SW-1, SW-2, and Central.

Part 4:Enable the Management PC to Access Router R1

Step 1:Enable a new subinterface on router R1.

  1. Create subinterface g0/0.3 and set encapsulation to dot1q 20 to account for VLAN 20.

R1(config)# interface g0/0.3

R1(config-subif)# encapsulation dot1q 20

  1. Assign an IP address within the 192.168.20.0/24 network.

R1(config)# interface g0/0.3

R1(config-subif)# ip address 192.168.20.100 255.255.255.0

Step 2:Verify connectivity between the management PC and R1.

Be sure to configure the default gateway on the management PC to allow for connectivity.

Step 3:Enable security.

While the management PC must be able to access the router, no other PC should be able to access the management VLAN.

  1. Create an ACL that allows only the Management PC to access the router.

Example: (may vary from student configuration)

R1(config)# access-list 101 deny ip any 192.168.20.0 0.0.0.255

R1(config)# access-list 101 permit ip any any

R1(config)# access-list 102 permit ip host 192.168.20.50 any

  1. Apply the ACL to the proper interface(s).

Example: (may vary from student configuration)

R1(config)# interface g0/0.1

R1(config-subif)# ip access-group 101 in

R1(config-subif)# interface g0/0.2

R1(config-subif)# ip access-group 101 in

R1(config-subif)# line vty 0 4

R1(config-line)# access-class 102 in

Note: Access list 102 is used to only allow the Management PC (192.168.20.50 in this example) to access the router. This prevents an IP address change to bypass the ACL.

Note: There are multiple ways in which an ACL can be created to accomplish the necessary security. For this reason, grading on this portion of the activity is based on the correct connectivity requirements. The management PC must be able to connect to all switches and the router. All other PCs should not be able to connect to any devices within the management VLAN.

Step 4:Verify security.

  1. Verify only the Management PC can access the router. Use SSH to access R1 with username SSHadmin and password ciscosshpa55.

PC> ssh -l SSHadmin 192.168.20.100

  1. From the management PC, ping SW-A, SW-B, and R1.

Question:

Were the pings successful? Explain.

Type your answers.

The pings should have been successful because all devices within the 192.168.20.0 network should be able to ping one another. Devices within VLAN20 are not required to route through the router.

  1. From D1, ping the management PC. Were the pings successful? Explain.

Type your answers here.

The ping should have failed because for a device within a different VLAN to successfully ping a device within VLAN20, it must be routed. The router has an ACL that prevents all packets from accessing the 192.168.20.0 network.

Step 5:Check results.

Your completion percentage should be 100%. Click Check Results to view feedback and verification of which required components have been completed.

If all components appear to be correct and the activity still shows incomplete, it could be due to the connectivity tests that verify the ACL operation.

Answer Scripts

SW-1

conf t

interface f0/23

switchport mode trunk

switchport trunk native vlan 15

switchport nonegotiate

no shutdown

vlan 20

exit

interface vlan 20

ip address 192.168.20.3 255.255.255.0

SW-2

conf t

interface f0/23

switchport mode trunk

switchport trunk native vlan 15

switchport nonegotiate

no shutdown

vlan 20

exit

interface vlan 20

ip address 192.168.20.4 255.255.255.0

SW-A

conf t

vlan 20

exit

interface vlan 20

ip address 192.168.20.1 255.255.255.0

interface f0/1

switchport access vlan 20

no shutdown

SW-B

conf t

vlan 20

exit

interface vlan 20

ip address 192.168.20.2 255.255.255.0

Central

conf t

vlan 20

exit

interface vlan 20

ip address 192.168.20.5 255.255.255.0

R1

conf t

interface GigabitEthernet0/0.1

ip access-group 101 in

interface GigabitEthernet0/0.2

ip access-group 101 in

interface g0/0.3

encapsulation dot1q 20

ip address 192.168.20.100 255.255.255.0

access-list 101 deny ip any 192.168.20.0 0.0.0.255

access-list 101 permit ip any any

access-list 102 permit ip host 192.168.20.50 any

line vty 0 4

access-class 102 in