15.1.4 Lab – Troubleshoot Route Maps and PBR Answers

Last Updated on February 27, 2021 by Admin

15.1.4 Lab – Troubleshoot Route Maps and PBR Answers

Lab – Troubleshoot Route Maps and PBR (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

This topology has 3 routers and 2 switches. D1 g1/0/11 is connected R1 G0/0/1. R1 G0/0/0 is connected to R2 G0/0/0. R1 S0/1/0 is connected to R3 S0/1/0. R2 G0/0/1 is connected to R3 G0/0/0. R3 G0/01 is connected to D2 G1/0/11.

Addressing Table

Device

Interface

IPv4 Address

Subnet Mask

D1

G0/0/11

10.10.0.2

255.255.255.252

D1

Loopback 1

10.10.1.1

255.255.255.0

D1

Loopback 2

10.10.2.1

255.255.255.0

R1

G0/0/0

172.16.0.2

255.255.255.252

R1

G0/0/1

10.10.0.1

255.255.255.252

R1

S0/1/0

172.16.2.1

255.255.255.252

R2

G0/0/0

172.16.0.1

255.255.255.252

R2

G0/0/1

172.16.1.1

255.255.255.252

R3

G0/0/0

172.16.1.2

255.255.255.252

R3

G0/0/1

192.168.0.1

255.255.255.252

R3

S0/1/0

172.16.2.2

255.255.255.252

D2

G0/0/11

192.168.0.2

255.255.255.252

D2

Loopback 1

192.168.1.1

255.255.255.0

Objectives

Troubleshoot network issues related to the configuration and operation of PBR using route maps.

Background / Scenario

PBR was recently implemented on R1 and R3. However, there have been problems.

Although the topology has a limited number of routers, you should use the appropriate troubleshooting commands to help find and solve the problems in the three trouble tickets as if this were a much more complex topology with many more routers and networks.

You will be loading configurations with intentional errors onto the network. Your tasks are to FIND the error(s), document your findings and the command(s) or method(s) used to fix them, FIX the issue(s) presented here, and then test the network to ensure both of the following conditions are met:

1)the complaint received in the ticket is resolved

2)full reachability is restored

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the devices have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3560 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1:Trouble Ticket 15.1.4.1

Scenario:

The routing table in the OSPF area 0 topology forwards traffic between R1 and R3 via R2 because of the faster Gigabit Ethernet links between R1 and R2 and between R2 and R3. However, corporate policy states that all traffic from the D1 loopback 2 network (i.e., 10.10.2.0/24) should be policy-based routed (PBR) directly to R3 using the R1 to R3 serial link. It was assumed that the policy was working correctly but a recent traceroute from the D1 loopback 2 interface to the D2 loopback 1 (i.e., 192.168.1.0/24) network has revealed otherwise.

D1# traceroute 192.168.1.1 source lo2

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.10.0.1 2 msec 2 msec 2 msec

2 172.16.0.1 2 msec 2 msec 2 msec

3 172.16.1.2 2 msec 2 msec 2 msec

4 192.168.0.2 3 msec *3 msec

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for uploading the configuration are provided at the end of this document.

Device

Command

R1

copy flash:/enarsi/15.1.4.1-r1-config.txt run

R2

copy flash:/enarsi/15.1.4.1-r2-config.txt run

R3

copy flash:/enarsi/15.1.4.1-r3-config.txt run

D1

copy flash:/enarsi/15.1.4.1-d1-config.txt run

D2

copy flash:/enarsi/15.1.4.1-d2-config.txt run

  • Traffic from 10.10.2.0/24 going to 192.168.1.0/24 should be routed directly to R3 from R1.
  • All other traffic from D1 should be propagated according to the routing table.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains one intentional error. The policy route-map was applied to the wrong interface on R1. It was incorrectly applied to the R1 G0/0/0 interface instead of the R1 G0/0/1 interface.

The commands used to fix this error should be:

R1(config)# interface G0/0/0

R1(config-if)# no ip policy route-map R1-to-R3

R1(config-if)# exit

R1(config)# interface G0/0/1

R1(config-if)# ip policy route-map R1-to-R3

After the issue is corrected, traceroutes from D1 should be as follows:

D1# traceroute 192.168.1.1 source 10.10.1.1

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.10.0.1 2 msec 2 msec 2 msec

2 172.16.0.1 2 msec 2 msec 2 msec

3 172.16.1.2 2 msec 2 msec 2 msec

4 192.168.0.2 3 msec *3 msec

D1# traceroute 192.168.1.1 source 10.10.2.1

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.10.0.1 2 msec 2 msec 1 msec

2 172.16.2.2 3 msec 2 msec 2 msec

3 192.168.0.2 3 msec *4 msec

Part 2:Trouble Ticket 15.1.4.2

Scenario:

The routing table in the OSPF area 0 topology forwards traffic between R1 and R3 via R2 because of the faster Gigabit Ethernet links between R1 and R2 and between R2 and R3. However, corporate policy states that all traffic from the D1 loopback 2 network (i.e., 10.10.2.0/24) should be policy-based routed (PBR) directly to R3 using the R1 to R3 serial link.

However, a traceroute from the D1 loopback 2 interface to the D2 loopback 1 (i.e., 192.168.1.0/24) network has revealed that traffic is not policy-based routed.

D1# traceroute 192.168.1.1 source lo2

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.10.0.1 2 msec 2 msec 2 msec

2 172.16.0.1 2 msec 2 msec 2 msec

3 172.16.1.2 2 msec 2 msec 2 msec

4 192.168.0.2 3 msec *3 msec

Note: This is the same issue as the previous ticket. However, the cause(s) and solution(s) are different.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/15.1.4.2-r1-config.txt run

R2

copy flash:/enarsi/15.1.4.2-r2-config.txt run

R3

copy flash:/enarsi/15.1.4.2-r3-config.txt run

D1

copy flash:/enarsi/15.1.4.2-d1-config.txt run

D2

copy flash:/enarsi/15.1.4.2-d2-config.txt run

  • Traffic from 10.10.2.0/24 going to 192.168.1.0/24 should be routed directly to R3 from R1.
  • All other traffic from D1 should be propagated according to the routing table.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains one intentional error. The permit sequence which states that any traffic matching the addresses in Lo2-ACL will be policy routed to the next-hop address 172.16.2.2. However, because the ip default next-hop command is used, the traffic will be policy-based routed if and only if there is no specific route in the routing table.

Therefore, PBR examines the routing table, and if there is a specific route in the routing table, it is used. If there is no specific route in the routing table, the packet is routed using policy-based routing. In our scenario, R1 does have a route to the 192.168.1.0/24 network. Therefore, the packets from D1 Lo2 are not routed using policy-based routing.

The commands used to fix this error should be:

R1(config)# no route-map R1-to-R3 permit 10

R1(config)# route-map R1-to-R3 permit 10

R1(config-route-map)# description RM to forward Lo2 traffic to R3

R1(config-route-map)# match ip address Lo2-ACL

R1(config-route-map)# set ip next-hop 172.16.2.2

After the issue is corrected, traceroutes from D1 should be as follows:

D1# traceroute 192.168.1.1 source 10.10.1.1

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.10.0.1 2 msec 2 msec 2 msec

2 172.16.0.1 2 msec 2 msec 2 msec

3 172.16.1.2 2 msec 2 msec 2 msec

4 192.168.0.2 3 msec *3 msec

D1# traceroute 192.168.1.1 source 10.10.2.1

Type escape sequence to abort.

Tracing the route to 192.168.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.10.0.1 2 msec 2 msec 1 msec

2 172.16.2.2 3 msec 2 msec 2 msec

3 192.168.0.2 3 msec *4 msec

Part 3:Trouble Ticket 15.1.4.3

Scenario:

In this scenario, a local PBR policy was implemented on R3 to route traffic generated for the 10.10.0.0/16 directly to R1. However, a traceroute to 10.10.1.1 displays that it is being forwarded to R2 instead of R1.

R3# traceroute 10.10.1.1

Type escape sequence to abort.

Tracing the route to 10.10.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 172.16.1.1 2 msec 1 msec 1 msec

2 172.16.0.2 2 msec 1 msec 1 msec

3 10.10.0.2 4 msec *2 msec

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/15.1.4.3-r1-config.txt run

R2

copy flash:/enarsi/15.1.4.3-r2-config.txt run

R3

copy flash:/enarsi/15.1.4.3-r3-config.txt run

D1

copy flash:/enarsi/15.1.4.3-d1-config.txt run

D2

copy flash:/enarsi/15.1.4.3-d2-config.txt run

  • Traffic generated by R3 going to the 10.10.0.0/16 networks should be sent directly to R1 as identified in the local PBR.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 1 error. On R3, the route map was accidentally configured to deny traffic.

The commands used to fix these errors should be:

R3(config)# no route-map LOCAL-PBR deny 10

R3(config)# route-map LOCAL-PBR permit 10

R3(config-route-map)# match ip address R3-TRAFFIC

R3(config-route-map)# set ip next-hop 172.16.2.1

Once corrected, traceroutes from R3 to the 10.10.0.0/16 networks should be as follows:

R3# traceroute 10.10.1.1

Type escape sequence to abort.

Tracing the route to 10.10.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 172.16.2.1 2 msec 2 msec 1 msec

2 10.10.0.2 3 msec *2 msec

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Uploading Configuration Files

Use the commands below to create the configuration files for each trouble ticket in this lab on the lab devices. The TCL script commands help create and copy the configurations. However, the configuration commands could also be copied and pasted directly into global config mode on each device. Simply remove the TCL script commands, enter the enable and configure t commands on the device, and copy and paste the configuration commands.

Important: The device requires a folder in flash named enarsi. Use the dir command to verify. If the folder is missing, then create it using the mkdir flash:/enarsi privileged EXEC command. For all switches, make sure the vlan.dat file is set to the default. Use the delete vlan.dat privileged EXEC command, if necessary.

Reset scripts

These TCL scripts will completely clear and reload the device in preparation for the next ticket. Copy and paste the appropriate script to the appropriate device.

Router Reset Script

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

puts “Reloading the router”

typeahead “\n”

reload

}

tclquit

D1/D2 (Cisco 3650) Reset Script – The default 3650 SDM template supports IPv6 by default, so it is not set by this script.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

puts “Reloading the switch”

typeahead “\n”

reload

}

tclquit

A1 (Cisco 2960 Script) – The default 2960 SDM template does not support IPv6, so this script includes that setting.

tclsh

puts [ open “flash:reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

delete /force multiple-fs

ios_config “sdm prefer lanbase-routing”

typeahead “\n”

puts “Reloading the switch in 1 minute, type reload cancel to halt”

typeahead “\n”

reload

}

tclquit

R1 Configuration File Scripts

!R1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/15.1.4.1-r1-config.txt” w+ ] {

hostname R1

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R1, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R2

ip add 172.16.0.2 255.255.255.252

no shut

exit

interface S0/1/0

description Serial Connection to R3

ip add 172.16.2.1 255.255.255.252

no shut

exit

interface G0/0/1

description Connection to D1

ip add 10.10.0.1 255.255.255.252

no shut

exit

router ospf 123

router-id 1.1.1.1

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 0

network 172.16.0.0 0.0.0.3 area 0

network 172.16.2.0 0.0.0.3 area 0

ip access-list standard Lo2-ACL

remark ACL matches D1 Lo2 traffic

permit 10.10.2.0 0.0.0.255

route-map R1-to-R3 permit

description RM to forward Lo2 traffic to R3

match ip address Lo2-ACL

set ip next-hop 172.16.2.2

exit

interface g0/0/0

ip policy route-map R1-to-R3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R1 – Trouble Ticket # 2-

tclsh

puts [ open “flash:/enarsi/15.1.4.2-r1-config.txt” w+ ] {

hostname R1

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R1, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R2

ip add 172.16.0.2 255.255.255.252

no shut

exit

interface S0/1/0

description Serial Connection to R3

ip add 172.16.2.1 255.255.255.252

no shut

exit

interface G0/0/1

description Connection to D1

ip add 10.10.0.1 255.255.255.252

no shut

exit

router ospf 123

router-id 1.1.1.1

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 0

network 172.16.0.0 0.0.0.3 area 0

network 172.16.2.0 0.0.0.3 area 0

ip access-list standard Lo2-ACL

remark ACL matches D1 Lo2 traffic

permit 10.10.2.0 0.0.0.255

route-map R1-to-R3 permit

description RM to forward Lo2 traffic to R3

match ip address Lo2-ACL

set ip default next-hop 172.16.2.2

exit

interface g0/0/1

ip policy route-map R1-to-R3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/15.1.4.3-r1-config.txt” w+ ] {

hostname R1

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R1, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R2

ip add 172.16.0.2 255.255.255.252

no shut

exit

interface S0/1/0

description Serial Connection to R3

ip add 172.16.2.1 255.255.255.252

no shut

exit

interface G0/0/1

description Connection to D1

ip add 10.10.0.1 255.255.255.252

no shut

exit

router ospf 123

router-id 1.1.1.1

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 0

network 172.16.0.0 0.0.0.3 area 0

network 172.16.2.0 0.0.0.3 area 0

ip access-list standard Lo2-ACL

remark ACL matches D1 Lo2 traffic

permit 10.10.2.0 0.0.0.255

route-map R1-to-R3 permit

description RM to forward Lo2 traffic to R3

match ip address Lo2-ACL

set ip next-hop 172.16.2.2

exit

interface g0/0/1

ip policy route-map R1-to-R3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

R2 Configuration File Scripts

!R2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/15.1.4.1-r2-config.txt” w+ ] {

hostname R2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R2, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R1

ip add 172.16.0.1 255.255.255.252

no shut

exit

interface GigabitEthernet0/0/1

description Connection to R3

ip address 172.16.1.1 255.255.255.252

no shut

exit

router ospf 123

router-id 2.2.2.1

auto-cost reference-bandwidth 1000

network 172.16.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/15.1.4.2-r2-config.txt” w+ ] {

hostname R2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R2, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R1

ip add 172.16.0.1 255.255.255.252

no shut

exit

interface GigabitEthernet0/0/1

description Connection to R3

ip address 172.16.1.1 255.255.255.252

no shut

exit

router ospf 123

router-id 2.2.2.1

auto-cost reference-bandwidth 1000

network 172.16.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/15.1.4.3-r2-config.txt” w+ ] {

hostname R2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R2, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R1

ip add 172.16.0.1 255.255.255.252

no shut

exit

interface GigabitEthernet0/0/1

description Connection to R3

ip address 172.16.1.1 255.255.255.252

no shut

exit

router ospf 123

router-id 2.2.2.1

auto-cost reference-bandwidth 1000

network 172.16.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

R3 Configuration File Scripts

!R3 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/15.1.4.1-r3-config.txt” w+ ] {

hostname R3

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R3, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R2

ip add 172.16.1.2 255.255.255.252

no shut

exit

interface S0/1/0

description Serial Connection to R1

ip add 172.16.2.2 255.255.255.252

no shut

exit

interface G0/0/1

description Connection to D2

ip add 192.168.0.1 255.255.255.252

no shut

exit

router ospf 123

router-id 3.3.3.1

auto-cost reference-bandwidth 1000

network 192.168.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

network 172.16.2.0 0.0.0.3 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R3 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/15.1.4.2-r3-config.txt” w+ ] {

hostname R3

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R3, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R2

ip add 172.16.1.2 255.255.255.252

no shut

exit

interface S0/1/0

description Serial Connection to R1

ip add 172.16.2.2 255.255.255.252

no shut

exit

interface G0/0/1

description Connection to D2

ip add 192.168.0.1 255.255.255.252

no shut

exit

router ospf 123

router-id 3.3.3.1

auto-cost reference-bandwidth 1000

network 192.168.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

network 172.16.2.0 0.0.0.3 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R3 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/15.1.4.3-r3-config.txt” w+ ] {

hostname R3

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R3, Troubleshoot Route Maps and PBR #

interface G0/0/0

description Connection to R2

ip add 172.16.1.2 255.255.255.252

no shut

exit

interface S0/1/0

description Serial Connection to R1

ip add 172.16.2.2 255.255.255.252

no shut

exit

interface G0/0/1

description Connection to D2

ip add 192.168.0.1 255.255.255.252

no shut

exit

router ospf 123

router-id 3.3.3.1

auto-cost reference-bandwidth 1000

network 192.168.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

network 172.16.2.0 0.0.0.3 area 0

exit

ip access-list extended R3-TRAFFIC

permit ip any 10.10.0.0 0.0.255.255

exit

route-map LOCAL-PBR deny

match ip address R3-TRAFFIC

set ip next-hop 172.16.2.1

exit

ip local policy route-map LOCAL-PBR

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

D1 Configuration File Scripts

!D1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/15.1.4.1-d1-config.txt” w+ ] {

hostname D1

no ip domain lookup

line con 0

exec-timeout 0 0

logging synchronous

exit

banner motd # This is D1, Troubleshoot Route Maps and PBR #

interface G1/0/11

no switchport

description Connects to R1

ip address 10.10.0.2 255.255.255.252

no shut

exit

interface Loopback 1

description Interface simulates network

ip ospf network point-to-point

ip address 10.10.1.1 255.255.255.0

exit

interface Loopback 2

description Interface simulates network

ip ospf network point-to-point

ip address 10.10.2.1 255.255.255.0

exit

int range G1/0/1 – 10, G1/0/12 – 24

shut

exit

ip routing

router ospf 123

router-id 1.1.1.2

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 0

network 10.10.1.0 0.0.0.255 area 0

network 10.10.2.0 0.0.0.255 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/15.1.4.2-d1-config.txt” w+ ] {

hostname D1

no ip domain lookup

line con 0

exec-timeout 0 0

logging synchronous

exit

banner motd # This is D1, Troubleshoot Route Maps and PBR #

interface G1/0/11

no switchport

description Connects to R1

ip address 10.10.0.2 255.255.255.252

no shut

exit

interface Loopback 1

description Interface simulates network

ip ospf network point-to-point

ip address 10.10.1.1 255.255.255.0

exit

interface Loopback 2

description Interface simulates network

ip ospf network point-to-point

ip address 10.10.2.1 255.255.255.0

exit

int range G1/0/1 – 10, G1/0/12 – 24

shut

exit

ip routing

router ospf 123

router-id 1.1.1.2

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 0

network 10.10.1.0 0.0.0.255 area 0

network 10.10.2.0 0.0.0.255 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/15.1.4.3-d1-config.txt” w+ ] {

hostname D1

no ip domain lookup

line con 0

exec-timeout 0 0

logging synchronous

exit

banner motd # This is D1, Troubleshoot Route Maps and PBR #

interface G1/0/11

no switchport

description Connects to R1

ip address 10.10.0.2 255.255.255.252

no shut

exit

interface Loopback 1

description Interface simulates network

ip ospf network point-to-point

ip address 10.10.1.1 255.255.255.0

exit

interface Loopback 2

description Interface simulates network

ip ospf network point-to-point

ip address 10.10.2.1 255.255.255.0

exit

int range G1/0/1 – 10, G1/0/12 – 24

shut

exit

ip routing

router ospf 123

router-id 1.1.1.2

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 0

network 10.10.1.0 0.0.0.255 area 0

network 10.10.2.0 0.0.0.255 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

D2 Configuration File Scripts

!D2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/15.1.4.1-d2-config.txt” w+ ] {

hostname D2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is D2, Troubleshoot Route Maps and PBR #

interface G1/0/11

no switchport

description Connects to R3

ip address 192.168.0.2 255.255.255.252

no shut

exit

interface Loopback 1

description Interface simulates network

ip ospf network point-to-point

ip address 192.168.1.1 255.255.255.0

exit

int range G1/0/1 – 10, G1/0/12 – 24

shut

exit

ip routing

router ospf 123

router-id 3.3.3.2

auto-cost reference-bandwidth 1000

network 192.168.0.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.255 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/15.1.4.2-d2-config.txt” w+ ] {

hostname D2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is D2, Troubleshoot Route Maps and PBR #

interface G1/0/11

no switchport

description Connects to R3

ip address 192.168.0.2 255.255.255.252

no shut

exit

interface Loopback 1

description Interface simulates network

ip ospf network point-to-point

ip address 192.168.1.1 255.255.255.0

exit

int range G1/0/1 – 10, G1/0/12 – 24

shut

exit

ip routing

router ospf 123

router-id 3.3.3.2

auto-cost reference-bandwidth 1000

network 192.168.0.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.255 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/15.1.4.3-d2-config.txt” w+ ] {

hostname D2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is D2, Troubleshoot Route Maps and PBR #

interface G1/0/11

no switchport

description Connects to R3

ip address 192.168.0.2 255.255.255.252

no shut

exit

interface Loopback 1

description Interface simulates network

ip ospf network point-to-point

ip address 192.168.1.1 255.255.255.0

exit

int range G1/0/1 – 10, G1/0/12 – 24

shut

exit

ip routing

router ospf 123

router-id 3.3.3.2

auto-cost reference-bandwidth 1000

network 192.168.0.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.255 area 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

A1 Configuration File Scripts – Not Used In This Lab

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments