17.1.2 Lab – Troubleshoot Redistribution Answers

Last Updated on February 27, 2021 by Admin

17.1.2 Lab – Troubleshoot Redistribution Answers

Lab – Troubleshoot Redistribution (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Objectives

Troubleshoot network issues related to redistribution.

Background / Scenario

In this topology D1, R1, and R2 are implementing OSPFv2. D1 is redistributing Loopback 0 into OSPFv2 area 10. R2 and R3 are BGP neighbors in AS 64512. You will be loading configurations with intentional errors or missing configurations onto the network. Your tasks are to FIND the error(s), document your findings and the command(s) or method(s) used to fix them, FIX the issue(s) presented here, and then test the network to ensure both of the following conditions are met:

1)the complaint received in the ticket is resolved

2)full reachability is restored

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the devices have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3560 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (Choice of operating system with terminal emulation program installed)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1:Trouble Ticket 17.1.2.1

Topology

This topology has 3 routers and 2 switches. D1 g1/0/11 is connected to R1 G0/0/1. R1 G0/0/0 is connected to R2 G0/0/0. R2 G0/0/1 is connected to R3 G0/0/0.

Addressing Table

Device

Interface

IP Address

Subnet Mask

R1

G0/0/0

10.1.12.1

255.255.255.0

R1

G0/0/1

10.1.10.1

255.255.255.0

R1

Loopback 0

10.1.1.1

255.255.255.0

R2

G0/0/0

10.1.12.2

255.255.255.0

R2

G0/0/1

192.168.23.2

255.255.255.0

R2

Loopback 0

192.168.2.1

255.255.255.0

R3

G0/0/0

192.168.23.3

255.255.255.0

R3

Loopback 0

209.165.201.1

255.255.255.128

D1

G1/0/11

10.1.10.2

255.255.255.0

D1

Loopback 0

198.51.100.1

255.255.255.128

Scenario:

During a routine maintenance window, router R2 was replaced and upgraded to support gigabit interfaces. Instead of modifying the previous R2 configuration to support gigabit interfaces and loading the configuration file on R2, the network engineer decided to type the IOS commands on R2 from memory. As a result, only partial redistribution is occurring between OSPFv2 and BGP. The network engineer requested your help in diagnosing and resolving the issue(s) to restore full connectivity.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for uploading the configuration are provided at the end of this document.

Device

Command

R1

copy flash:/enarsi/17.1.2.1-r1-config.txt run

R2

copy flash:/enarsi/17.1.2.1-r2-config.txt run

R3

copy flash:/enarsi/17.1.2.1-r3-config.txt run

D1

copy flash:/enarsi/17.1.2.1-d1-config.txt run

  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • After you have fixed the ticket, change the MOTD on EACH DEVICE using the following command

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains two intentional errors:

1)By default, BGP only redistributes eBGP routes into an Interior Gateway Protocol, such as OSPF. To redistribute iBGP routes into OSPF requires the bgp redistribute-internal command.

2)By default, when redistributing OSPF into BGP only intra-area and inter-area OSPF routes are “matched” for redistribution. To redistribute external OSPF routes required the redistribute ospf 1 match internal external 1 external 2 command.

The commands used to fix the first error should be:

R2(config)# router bgp 64512

R2(config-router)# address-family ipv4

R2(config-routeraf)# bgp redistribute-internal

R2(config-router-af)# end

The commands used to fix the second error should be:

R2(config)# router bgp 64512

R2(config-router)# address-family ipv4

R2(config-router-af)# redistribute ospf 1 match internal external 1 external 2

R2(config-router-af)# end

Part 2:Trouble Ticket 17.1.2.2

Topology

This topology has 3 routers and 2 switches. D1 g1/0/11 is connected to R1 G0/0/1. R1 G0/0/0 is connected to R2 G0/0/0. R2 G0/0/1 is connected to R3 G0/0/0. R3 G0/0/1 is connected d2 G1/0/11.

Addressing Table

Device

Interface

IPv4 Address/Mask

IPv6 Address/Prefix

IPv6 Link Local

R1

G0/0/0

10.1.12.1/24

2001:db8:acad:12::1/64

fe80::12:1

R1

G0/0/1

10.1.11.1/24

2001:db8:acad:11::1/64

fe80::11:1

R1

Loopback 0

10.1.1.1/24

2001:db8:acad:1::1/64

fe80::1:1

R2

G0/0/0

10.1.12.2/24

2001:db8:acad:12::2/64

fe80::12:2

R2

G0/0/1

10.1.23.2/24

2001:db8:acad:23::2/64

fe80::23:2

R3

G0/0/0

10.1.23.3/24

2001:db8:acad:23::3/64

fe80::23:3

R3

G0/0/1

10.1.32.1/24

2001:db8:acad:32::3/64

fe80::32:3

R3

Loopback 0

10.3.3.3/24

2001:db8:acad:3::3/64

fe80::3:3

D1

G1/0/11

10.1.11.2/24

2001:db8:acad:11::2/64

fe80::11:2

D1

Loopback 0

209.165.201.1/25

2001:db8:209:165:201::1/80

fe80::209:1

D2

G1/0/11

10.1.32.2/24

2001:db8:acad:32::2/64

fe80::32:2

D2

Loopback 0

198.51.100.1/25

2001:db8:198:51:100::1/80

fe80::198:1

Scenario:

R2 is performing route redistribution between OSPFv3 AF and Named EIGRP for IPv4 and IPv6. During a routine maintenance window, router R2 was upgraded. As a result, redistribution is not occurring for IPv4 between OSPFv3 and named EIGRP.

Use the commands listed below to load the configuration files for this trouble ticket:

Device

Command

R1

copy flash:/enarsi/17.1.2.2-r1-config.txt run

R2

copy flash:/enarsi/17.1.2.2-r2-config.txt run

R3

copy flash:/enarsi/17.1.2.2-r3-config.txt run

D1

copy flash:/enarsi/17.1.2.2-d1-config.txt run

D2

copy flash:/enarsi/17.1.2.2-d2-config.txt run

  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • After you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, proceed to troubleshoot IPv6 redistribution.

Answers Notes:

This IPv4 trouble ticket contains two intentional errors:

1)OSPFv3 routes being redistributed into EIGRP are not getting the correct seed metric within the route map.

2)Redistribution of EIGRP routes into OSPFv3 is configured with the wrong EIGRP AS number.

The commands used to fix the first error should be:

R2(config)# no route-map OSPF-into-EIGRP permit 10

R2(config)# route-map OSPF-into-EIGRP permit 10

R2(config-route-map)# set metric 1000000 10 255 1 1500

The commands used to fix the second error should be:

R2(config)# router ospfv3 1

R2(config-router)# address-family ipv4

R2(config-router-af)# no redistribute EIGRP 64521 metric 25 metric-type 1

R2(config-router-af)# redistribute EIGRP 64512 metric 25 metric-type 1

Part 3:Trouble Ticket 17.1.2.3

Topology

This topology has 3 routers and 2 switches. D1 g1/0/11 is connected to R1 G0/0/1. R1 G0/0/0 is connected to R2 G0/0/0. R2 G0/0/1 is connected to R3 G0/0/0. R3 G0/0/1 is connected d2 G1/0/11.

Addressing Table

Device

Interface

IPv4 Address/Mask

IPv6 Address/Prefix

IPv6 Link Local

R1

G0/0/0

10.1.12.1/24

2001:db8:acad:12::1/64

fe80::12:1

R1

G0/0/1

10.1.11.1/24

2001:db8:acad:11::1/64

fe80::11:1

R1

Loopback 0

10.1.1.1/24

2001:db8:acad:1::1/64

fe80::1:1

R2

G0/0/0

10.1.12.2/24

2001:db8:acad:12::2/64

fe80::12:2

R2

G0/0/1

10.1.23.2/24

2001:db8:acad:23::2/64

fe80::23:2

R3

G0/0/0

10.1.23.3/24

2001:db8:acad:23::3/64

fe80::23:3

R3

G0/0/1

10.1.32.1/24

2001:db8:acad:32::3/64

fe80::32:3

R3

Loopback 0

10.3.3.3/24

2001:db8:acad:3::3/64

fe80::3:3

D1

G1/0/11

10.1.11.2/24

2001:db8:acad:11::2/64

fe80::11:2

D1

Loopback 0

209.165.201.1/25

2001:db8:209:165:201::1/80

fe80::209:1

D2

G1/0/11

10.1.32.2/24

2001:db8:acad:32::2/64

fe80::32:2

D2

Loopback 0

198.51.100.1/25

2001:db8:198:51:100::1/80

fe80::198:1

Scenario:

R2 is performing route redistribution between OSPFv3 AF and Named EIGRP for IPv4 and IPv6. During a routine maintenance window router R2 was upgraded. As a result, IPv6 has limited connectivity and only partial redistribution is occurring between OSPFv3 and named EIGRP for IPv6.

Use the previously loaded 17.1.2.2 configuration files for trouble ticket 17.1.2.3:

  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • After you have fixed the ticket, change the MOTD on EACH DEVICE using the following command

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This IPv6 trouble ticket contains two intentional errors:

1)OSPFv3 routes being redistributed into named EIGRP require a seed metric.

2)The Loopback 0 Ipv6 address on S2 is being filtered during redistribution into OSPFv3.

The commands used to fix the first error should be:

R2(config)# router eigrp CISCO

R2(config-router)# address-family ipv6 autonomous-system 64512

R2(config-router-af)# topology base

R2(config-router-aftopology)# default-metric 1000000 10 255 1 1500

or

R2(config-router-aftopology)# redistribute ospf 1 metric 1000000 10 255 1 1500 include-connected

The commands used to fix the second error should be:

R2(config)# ipv6 prefix-list EIGRP-into-OSPF seq 10 permit 2001:DB8::/32 ge 80 le 80

or

R2(config)# no ipv6 prefix-list EIGRP-into-OSPF seq 5 permit 2001:DB8::/32 ge 64 le 64

R2(config)# ipv6 prefix-list EIGRP-into-OSPF seq 5 permit 2001:DB8::/32 ge 64 le 80

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Uploading Configuration Files

Use the commands below to create the configuration files on the lab devices for each trouble ticket in this lab. The TCL script commands help create and copy the configurations. However, the configuration commands could also be copied and pasted directly into global config mode on each device. Simply remove the TCL script commands, enter the enable and configure t commands on the device, and copy and paste the configuration commands.

Important: The device requires a folder in flash named enarsi. Use the dir command to verify. If the folder is missing, then create it using the mkdir flash:/enarsi privileged EXEC command. For all switches, make sure the vlan.dat file is set to the default. Use the delete vlan.dat privileged EXEC command, if necessary.

Reset scripts

These TCL scripts will completely clear and reload the device in preparation for the next ticket. Copy and paste the appropriate script to the appropriate device.

Router Reset Script

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

puts “Reloading the router”

typeahead “\n”

reload

}

tclquit

D1/D2 (Cisco 3650) Reset Script – The default 3650 SDM template supports IPv6 by default, so it is not set by this script.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

puts “Reloading the switch”

typeahead “\n”

reload

}

tclquit

R1 Configuration File Scripts

!R1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/17.1.2.1-r1-config.txt” w+ ] {

hostname R1

no ip domain lookup

banner motd # This is R1, Trouble Ticket 17.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.1.12.1 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 10.1.10.1 255.255.255.0

no shutdown

exit

inter lo 0

ip add 10.1.1.1 255.255.255.0

ip ospf network point-to-point

no shutdown

exit

router ospf 1

router-id 1.1.1.1

network 10.1.1.0 0.0.0.255 area 0

network 10.1.10.0 0.0.0.255 area 10

network 10.1.12.0 0.0.0.255 area 0

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R1 – Trouble Ticket # 2 and 3

!R1 – Trouble Ticket # 2 and 3

tclsh

puts [ open “flash:/enarsi/17.1.2.2-r1-config.txt” w+ ] {

hostname R1

no ip domain lookup

banner motd # This is R1, Trouble Ticket 17.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

ipv6 unicast-routing

hostname R1

router ospfv3 1

router-id 1.1.1.1

exit

interface Loopback0

ip address 10.1.1.1 255.255.255.0

ipv6 address FE80::1:1 link-local

ipv6 address 2001:DB8:ACAD:1::1/64

ospfv3 network point-to-point

ospfv3 1 ipv4 area 0

ospfv3 1 ipv6 area 0

no shutdown

exit

interface GigabitEthernet0/0/0

ip address 10.1.12.1 255.255.255.0

negotiation auto

ipv6 address FE80::12:1 link-local

ipv6 address 2001:DB8:ACAD:12::1/64

ospfv3 1 ipv6 area 0

ospfv3 1 ipv4 area 0

no shutdown

exit

interface GigabitEthernet0/0/1

ip address 10.1.11.1 255.255.255.0

negotiation auto

ipv6 address FE80::11:1 link-local

ipv6 address 2001:DB8:ACAD:11::1/64

ospfv3 1 ipv4 area 11

ospfv3 1 ipv6 area 11

no shutdown

exit

router ospfv3 1

address-family ipv4 unicast

passive-interface Loopback0

exit-address-family

address-family ipv6 unicast

passive-interface Loopback0

exit-address-family

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

R2 Configuration File Scripts

!R2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/17.1.2.1-r2-config.txt” w+ ] {

hostname R2

no ip domain lookup

banner motd # This is R2, Trouble Ticket 17.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.1.12.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 192.168.23.2 255.255.255.0

no shutdown

exit

inter lo 0

ip add 192.168.2.1 255.255.255.0

no shut

exit

router ospf 1

router-id 2.2.2.2

redistribute bgp 64512 subnets

network 10.1.12.2 0.0.0.0 area 0

router bgp 64512

bgp router-id 2.2.2.2

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 192.168.23.3 remote-as 64512

address-family ipv4

network 192.168.2.0

network 192.168.23.0

redistribute ospf 1

neighbor 192.168.23.3 activate

exit-address-family exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R2 – Trouble Ticket # 2 and 3

tclsh

puts [ open “flash:/enarsi/17.1.2.2-r2-config.txt” w+ ] {

hostname R2

no ip domain lookup

banner motd # This is R2, Trouble Ticket 17.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

no ip domain lookup

ipv6 unicast-routing

router ospfv3 1

router-id 2.2.2.2

exit

interface GigabitEthernet0/0/0

ip address 10.1.12.2 255.255.255.0

negotiation auto

ipv6 address FE80::12:2 link-local

ipv6 address 2001:DB8:ACAD:12::2/64

ospfv3 1 ipv4 area 0

ospfv3 1 ipv6 area 0

no shut

exit

interface GigabitEthernet0/0/1

ip address 10.1.23.2 255.255.255.0

negotiation auto

ipv6 address FE80::23:2 link-local

ipv6 address 2001:DB8:ACAD:23::2/64

no shut

router eigrp CISCO

address-family ipv4 unicast autonomous-system 64512

af-interface default

shutdown

exit-af-interface

af-interface GigabitEthernet0/0/1

no shutdown

exit-af-interface

topology base

redistribute ospfv3 1 route-map OSPF-into-EIGRP

exit-af-topology

network 10.1.23.0 0.0.0.255

eigrp router-id 2.2.2.2

exit-address-family

address-family ipv6 unicast autonomous-system 64512

af-interface default

shutdown

exit-af-interface

af-interface GigabitEthernet0/0/1

no shutdown

exit-af-interface

topology base

redistribute ospf 1 include-connected

exit-af-topology

exit-address-family

router ospfv3 1

address-family ipv4 unicast

redistribute eigrp 64521 metric 25 metric-type 1

exit-address-family

address-family ipv6 unicast

distribute-list prefix-list EIGRP-into-OSPF out eigrp 64512

redistribute eigrp 64512 include-connected

exit-address-family

exit

ipv6 prefix-list EIGRP-into-OSPF seq 5 permit 2001:DB8::/32 ge 64 le 64

route-map OSPF-into-EIGRP permit 10

set metric 100

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

R3 Configuration File Scripts

!R3 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/17.1.2.1-r3-config.txt” w+ ] {

hostname R3

no ip domain lookup

banner motd # This is R3, Trouble Ticket 17.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 192.168.23.3 255.255.255.0

no shutdown

exit

interface loopback 0

ip address 209.165.201.1 255.255.255.128

exit

router bgp 64512

bgp router-id 3.3.3.3

no bgp default ipv4-unicast

neighbor 192.168.23.2 remote-as 64512

address-family ipv4

network 209.165.201.0 mask 255.255.255.128

neighbor 192.168.23.2 activate

exit-address-family

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R3 – Trouble Ticket # 2 and 3

tclsh

puts [ open “flash:/enarsi/17.1.2.2-r3-config.txt” w+ ] {

hostname R3

no ip domain lookup

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

ipv6 unicast-routing

interface Loopback0

ip address 10.3.3.3 255.255.255.0

ipv6 address FE80::3:3 link-local

ipv6 address 2001:DB8:ACAD:3::3/64

no shut

exit

interface GigabitEthernet0/0/0

ip address 10.1.23.3 255.255.255.0

negotiation auto

ipv6 address FE80::23:3 link-local

ipv6 address 2001:DB8:ACAD:23::3/64

no shut

exit

interface GigabitEthernet0/0/1

ip address 10.1.32.3 255.255.255.0

negotiation auto

ipv6 address FE80::32:3 link-local

ipv6 address 2001:DB8:ACAD:32::3/64

no shut

exit

router eigrp CISCO

address-family ipv4 unicast autonomous-system 64512

af-interface default

shutdown

exit-af-interface

af-interface GigabitEthernet0/0/0

no shutdown

exit-af-interface

af-interface GigabitEthernet0/0/1

no shutdown

exit-af-interface

af-interface Loopback0

no shutdown

exit-af-interface

topology base

exit-af-topology

network 10.1.23.0 0.0.0.255

network 10.1.32.0 0.0.0.255

network 10.3.3.0 0.0.0.255

eigrp router-id 3.3.3.3

exit-address-family

address-family ipv6 unicast autonomous-system 64512

af-interface default

shutdown

exit-af-interface

af-interface GigabitEthernet0/0/0

no shutdown

exit-af-interface

af-interface GigabitEthernet0/0/1

no shutdown

exit-af-interface

af-interface Loopback0

no shutdown

exit-af-interface

topology base

exit-af-topology

eigrp router-id 3.3.3.3

exit-address-family

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

D1 Configuration File Scripts

!D1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/17.1.2.1-d1-config.txt” w+ ] {

hostname D1

ip routing

no ip domain lookup

banner motd # This is D1, Trouble Ticket 17.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface range g1/0/1 – 24

shutdown

exit

interface g1/0/11

no switchport

ip address 10.1.10.2 255.255.255.0

no shutdown

exit

interface Loopback0

ip address 198.51.100.1 255.255.255.128

exit

router ospf 1

router-id 11.11.11.11

redistribute connected subnets tag 110

network 10.1.10.0 0.0.0.255 area 10

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!D1 – Trouble Ticket # 2 and 3

tclsh

puts [ open “flash:/enarsi/17.1.2.2-d1-config.txt” w+ ] {

hostname D1

no ip domain lookup

ip routing

ipv6 unicast-routing

banner motd # This is D1, Trouble Ticket 17.1.2.2#

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface range g1/0/1-24

switchport mode access

shutdown

exit

interface g1/0/11

no switchport

ip address 10.1.11.2 255.255.255.0

ipv6 address FE80::11:2 link-local

ipv6 address 2001:DB8:ACAD:11::2/64

no shutdown

exit

interface loopback 0

ip address 209.165.201.1 255.255.255.128

ipv6 address fe80::209:1 link-local

ipv6 address 2001:db8:209:165:201::1/80

no shutdown

exit

router ospfv3 1

router-id 11.11.11.11

address-family ipv4 unicast

passive-interface loopback 0

default-information originate

address-family ipv6 unicast

passive-interface loopback 0

default-information originate

exit

exit

interface g1/0/11

ospfv3 1 ipv6 area 11

ospfv3 1 ipv4 area 11

exit

ip route 0.0.0.0 0.0.0.0 loopback 0

ipv6 route ::/0 loopback 0

line con 0

logging synchronous

exec-timeout 0 0

exit

line vty 0 4

login local

transport input telnet

exec-timeout 5 0

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

D2 Configuration File Scripts – Not Used In Trouble Ticket 1

!D2 – Trouble Ticket # 2 and 3

tclsh

puts [ open “flash:/enarsi/17.1.2.2-d2-config.txt” w+ ] {

hostname D2

no ip domain lookup

banner motd # This is D2, Trouble Ticket 17.1.2.2 #

ip routing

ipv6 unicast-routing

interface GigabitEthernet1/0/11

no switchport

ip address 10.1.32.2 255.255.255.0

ipv6 address FE80::32:2 link-local

ipv6 address 2001:DB8:ACAD:32::2/64

no shut

exit

interface Loopback0

ip address 198.51.100.1 255.255.255.128

ipv6 address FE80::198:2 link-local

ipv6 address 2001:DB8:198:51:100::1/80

no shut

exit

router eigrp CISCO

address-family ipv4 unicast autonomous-system 64512

af-interface default

shutdown

exit-af-interface

af-interface Loopback0

no shutdown

passive-interface

exit-af-interface

af-interface GigabitEthernet1/0/11

no shutdown

exit-af-interface

topology base

exit-af-topology

network 10.1.32.0 0.0.0.255

network 198.51.100.0 0.0.0.127

eigrp router-id 22.22.22.22

exit-address-family

address-family ipv6 unicast autonomous-system 64512

af-interface default

shutdown

exit-af-interface

af-interface Loopback0

no shutdown

passive-interface

exit-af-interface

af-interface GigabitEthernet1/0/11

no shutdown

exit-af-interface

topology base

exit-af-topology

eigrp router-id 22.22.22.22

exit-address-family

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

A1 Configuration File Scripts – Not Used In This Lab

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments