4.1.2 Lab – Troubleshoot EIGRP for IPv4 Answers

Last Updated on February 27, 2021 by Admin

4.1.2 Lab – Troubleshoot EIGRP for IPv4 Answers

Lab – Troubleshoot EIGRP for IPv4 (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

This topology has 3 routers, 2 switches, and 1 PC. PC1 is connected to D1 G1/0/23. D1 G1/0/11 is connected to R1 G0/0/1. R1 g0/0/0 is connected to R2 g0/0/0. R2 G0/0/1 is connected to R3 G0/0/0. R3 G0/0/1 is connected to D2 G1/0/11. D2 G1/0/1 is connected to D1 G1/0/1.

Addressing Table

Device

Interface

IP Address

Subnet Mask

R1

G0/0/0

10.0.12.1

255.255.255.0

R1

G0/0/1.1

172.16.1.1

255.255.255.0

R1

G0/0/1.2

192.168.1.1

255.255.255.0

R2

G0/0/0

10.0.12.2

255.255.255.0

R2

G0/0/1

10.0.23.1

255.255.255.0

R3

G0/0/0

10.0.23.2

255.255.255.0

R3

G0/0/1

172.16.1.2

255.255.255.0

R3

Loopback 0

192.168.3.1

255.255.255.0

PC1

NIC

DHCP

Objectives

Troubleshoot network issues related to the configuration and operation of EIGRP for IPv4.

Background / Scenario

In this topology, routers R1, R2, and R3 are EIGRP neighbors. Switches D1 and D2 provide connectivity between R1 and R3. Router R1 is configured for interVLAN routing and DHCP to provide support for PC 1. You will be loading configurations with intentional errors onto the network. Your tasks are to FIND the error(s), document your findings and the command(s) or method(s) used to fix them. FIX the issue(s) presented here and then test the network to ensure both of the following conditions are met:

1)the complaint received in the ticket is resolved

2)full reachability is restored

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650s with Cisco IOS XE Release 16.9.4 (universalk9 image) and Cisco Catalyst 2960s with Cisco IOS Release 15.2(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3560 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (Choice of operating system with terminal emulation program installed)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1:Trouble Ticket 4.1.2.1

Scenario:

R2 was added to the network to increase bandwidth for traffic between the R1 and R3 LANs. However, R2, is not sending routes to R1 or forming adjacencies with R3.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for uploading the configuration are provided at the end of this document.

Device

Command

R1

copy flash:/enarsi/4.1.2.1-r1-config.txt run

R2

copy flash:/enarsi/4.1.2.1-r2-config.txt run

R3

copy flash:/enarsi/4.1.2.1-r3-config.txt run

D1

copy flash:/enarsi/4.1.2.1-d1-config.txt run

D2

copy flash:/enarsi/4.1.2.1-d2-config.txt run

  • PC 1 should be configured for and receive an address from an IPv4 DHCP server.
  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • After you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command on each device. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains two intentional errors:

1)R2 is configured with the same Router-ID as R1

2)R3 has interface g0/0/0 marked passive

The commands used to fix these errors should be:

R2(config)# router eigrp 412

R2(config-router)# eigrp router-id 2.2.2.2

R2(config-router)# end

R3(config)# router eigrp 412

R3(config-router)# no passive-interface g0/0/0

R3(config-router)# end

Note: Student may choose to issue the command no passive-interface default. This solves the adjacency issue with R2 but would open the router up to possible undesired adjacencies if there were more L3 interfaces configured.

Part 2:Trouble Ticket 4.1.2.2

Scenario:

Your company hired an outside security consultant to work on the network. His task was to ensure that routing was being done securely. After he completed his work, R2 stopped sharing route information about networks at R1.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/4.1.2.2-r1-config.txt run

R2

copy flash:/enarsi/4.1.2.2-r2-config.txt run

R3

copy flash:/enarsi/4.1.2.2-r3-config.txt run

D1

copy flash:/enarsi/4.1.2.2-d1-config.txt run

D2

copy flash:/enarsi/4.1.2.2-d2-config.txt run

  • PC1 should be configured for and receive an address from an IPv4 DHCP server.
  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • After you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 1 intentional error. R2 has a distribute list that is blocking the networks. The distribute list should be removed.

The commands used to fix these errors should be:

R2(config)# router eigrp 412

R2(config-router)# no distribute-list prefix 88QRX-T13 out g0/0/1

R2(config-router)# end

Part 3:Trouble Ticket 4.1.2.3

Topology Update:

This topology has 3 routers, 2 switches, and 1 PC. PC1 is connected to D1 G1/0/23. D1 G1/0/11 is connected to R1 G0/0/1. R1 g0/0/0 is connected to R2 g0/0/0. R2 G0/0/1 is connected to R3 G0/0/0. R3 G0/0/1 is connected to D2 G1/0/11. D2 G1/0/1 is connected to D1 G1/0/1.

Addressing Table Update:

Device

Interface

IP Address

Subnet Mask

R1

G0/0/0

10.0.12.1

255.255.255.0

R1

G0/0/1.1

172.16.1.1

255.255.255.0

R1

G0/0/1.2

192.168.1.1

255.255.255.0

R2

G0/0/0

10.0.12.2

255.255.255.0

R2

G0/0/1

10.0.23.1

255.255.255.0

R3

G0/0/0

10.0.23.2

255.255.255.0

R3

G0/0/1

172.16.1.2

255.255.255.0

R3

Loopback 0

192.168.3.1

255.255.255.0

D2

G1/0/1

172.16.1.2

255.255.255.0

D2

G1/0/11

172.16.13.2

255.255.255.0

D2

Loopback 0

192.168.20.1

255.255.255.0

D2

Loopback 1

192.168.21.1

255.255.255.0

PC1

NIC

DHCP

Scenario:

Switch D2 was converted to support Inter-VLAN routing and is connected to the network via two routed ports. Switch D2 was also configured to join the EIGRP domain, but it is not forming adjacencies.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/4.1.2.3-r1-config.txt run

R2

copy flash:/enarsi/4.1.2.3-r2-config.txt run

R3

copy flash:/enarsi/4.1.2.3-r3-config.txt run

D1

copy flash:/enarsi/4.1.2.3-d1-config.txt run

D2

copy flash:/enarsi/4.1.2.3-d2-config.txt run

  • PC1 should be configured for and receive an address from an IPv4 DHCP server.
  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • After you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 1 intentional error, which is repeated in three places. The D2 EIGRP AS # is incorrect, which impacts the EIGRP configuration as well as the authentication commands on interface g1/0/1 and g1/0/11.

The commands used to fix these errors should be:

D2(config)# no router eigrp 421

D2(config)# router eigrp 412

D2(config-router)# eigrp router-id 132.132.132.132

D2(config-router)# network 172.16.1.0 0.0.0.255

D2(config-router)# network 172.16.13.0 0.0.0.255

D2(config-router)# network 192.168.20.0 0.0.0.255

D2(config-router)# network 192.168.21.0 0.0.0.255

D2(config-router)# exit

D2(config)# interface g1/0/1

D2(config-if)# ip authentication mode eigrp 412 md5

D2(config-if)# ip authentication key-chain eigrp 412 security

D2(config-if)# exit

D2(config)# interface g1/0/11

D2(config-if)# ip authentication mode eigrp 412 md5

D2(config-if)# ip authentication key-chain eigrp 412 security

D2(config-if)# end

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Uploading Configuration Files

Use the commands below to create the configuration files on the lab devices for each trouble ticket in this lab. The TCL script commands help create and copy the configurations. However, the configuration commands could also be copied and pasted directly into global config mode on each device. Simply remove the TCL script commands, enter the enable and configure t commands on the device, and copy and paste the configuration commands.

Important: The device requires a folder in flash named enarsi. Use the dir command to verify. If the folder is missing, then create it using the mkdir flash:/enarsi privileged EXEC command. For all switches, make sure the vlan.dat file is set to the default. Use the delete vlan.dat privileged EXEC command, if necessary.

Reset scripts

These TCL scripts will completely clear and reload the device in preparation for the next ticket. Copy and paste the appropriate script to the appropriate device.

Router Reset Script

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

puts “Reloading the router”

typeahead “\n”

reload

}

tclquit

D1/D2 (Cisco 3650) Reset Script – The default 3650 SDM template supports IPv6, so it is not set by this script.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

puts “Reloading the switch”

typeahead “\n”

reload

}

tclquit

A1 (Cisco 2960 Script) – The default 2960 SDM template does not support IPv6, so this script includes that setting.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

delete /force multiple-fs

ios_config “sdm prefer lanbase-routing”

typeahead “\n”

puts “Reloading the switch in 1 minute, type reload cancel to halt”

typeahead “\n”

reload

}

tclquit

R1 Configuration File Scripts

!R1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/4.1.2.1-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 4.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.12.1 255.255.255.0

no shutdown

exit

interface g0/0/1

no ip address

no shutdown

exit

interface g0/0/1.1

encapsulation dot1q 1 native

ip address 172.16.1.1 255.255.255.0

no shutdown

exit

interface g0/0/1.2

encapsulation dot1q 2

ip address 192.168.1.1 255.255.255.0

no shutdown

exit

router eigrp 412

eigrp router-id 1.1.1.1

network 10.0.12.0 0.0.0.255

network 172.16.1.0 0.0.0.255

network 192.168.1.0 0.0.0.255

passive-interface g0/0/1.2

exit

ip dhcp excluded-address 192.168.1.1 192.168.1.5

ip dhcp pool HOSTS

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/4.1.2.2-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 4.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.12.1 255.255.255.0

no shutdown

exit

interface g0/0/1

no ip address

no shutdown

exit

interface g0/0/1.1

encapsulation dot1q 1 native

ip address 172.16.1.1 255.255.255.0

no shutdown

exit

interface g0/0/1.2

encapsulation dot1q 2

ip address 192.168.1.1 255.255.255.0

no shutdown

exit

router eigrp 412

eigrp router-id 1.1.1.1

network 10.0.12.0 0.0.0.255

network 172.16.1.0 0.0.0.255

network 192.168.1.0 0.0.0.255

passive-interface g0/0/1.2

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g0/0/0

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

interface g0/0/1.1

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

ip dhcp excluded-address 192.168.1.1 192.168.1.5

ip dhcp pool HOSTS

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/4.1.2.3-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 4.1.2.3 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.12.1 255.255.255.0

no shutdown

exit

interface g0/0/1

no ip address

no shutdown

exit

interface g0/0/1.1

encapsulation dot1q 1 native

ip address 172.16.1.1 255.255.255.0

no shutdown

exit

interface g0/0/1.2

encapsulation dot1q 2

ip address 192.168.1.1 255.255.255.0

no shutdown

exit

router eigrp 412

eigrp router-id 1.1.1.1

network 10.0.12.0 0.0.0.255

network 172.16.1.0 0.0.0.255

network 192.168.1.0 0.0.0.255

passive-interface g0/0/1.2

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g0/0/0

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

interface g0/0/1.1

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

ip dhcp excluded-address 192.168.1.1 192.168.1.5

ip dhcp pool HOSTS

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

R2 Configuration File Scripts

!R2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/4.1.2.1-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 4.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.12.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 10.0.23.1 255.255.255.0

no shutdown

exit

router eigrp 412

eigrp router-id 1.1.1.1

network 10.0.12.0 0.0.0.255

network 10.0.23.0 0.0.0.255

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/4.1.2.2-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 4.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.12.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 10.0.23.1 255.255.255.0

no shutdown

exit

ip prefix-list 88QRX-T13 seq 5 deny 172.16.0.0/16 le 24

ip prefix-list 88QRX-T13 seq 10 deny 192.168.0.0/16 le 24

ip prefix-list 88QRX-T13 seq 15 deny 10.0.0.0/8 le 24

ip prefix-list 88QRX-T13 seq 20 permit 0.0.0.0/0 le 32

router eigrp 412

eigrp router-id 2.2.2.2

network 10.0.12.0 0.0.0.255

network 10.0.23.0 0.0.0.255

distribute-list prefix 88QRX-T13 out g0/0/1

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g0/0/0

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

interface g0/0/1

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/4.1.2.3-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 4.1.2.3 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.12.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 10.0.23.1 255.255.255.0

no shutdown

exit

router eigrp 412

eigrp router-id 2.2.2.2

network 10.0.12.0 0.0.0.255

network 10.0.23.0 0.0.0.255

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g0/0/0

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

interface g0/0/1

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

R3 Configuration File Scripts

!R3 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/4.1.2.1-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 4.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.23.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 172.16.1.2 255.255.255.0

no shutdown

exit

interface loopback 0

ip address 192.168.3.1 255.255.255.0

router eigrp 412

eigrp router-id 3.3.3.3

network 10.0.23.0 0.0.0.255

network 172.16.1.0 0.0.0.255

network 192.168.3.0 0.0.0.255

passive-interface default

no passive-interface g0/0/1

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R3 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/4.1.2.2-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 4.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.23.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 172.16.1.2 255.255.255.0

no shutdown

exit

interface loopback 0

ip address 192.168.3.1 255.255.255.0

router eigrp 412

eigrp router-id 3.3.3.3

network 10.0.23.0 0.0.0.255

network 172.16.1.0 0.0.0.255

network 192.168.3.0 0.0.0.255

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g0/0/0

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

interface g0/0/1

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!R3 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/4.1.2.3-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 4.1.2.3 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

interface g0/0/0

ip address 10.0.23.2 255.255.255.0

no shutdown

exit

interface g0/0/1

ip address 172.16.13.1 255.255.255.0

no shutdown

exit

interface loopback 0

ip address 192.168.3.1 255.255.255.0

router eigrp 412

eigrp router-id 3.3.3.3

network 10.0.23.0 0.0.0.255

network 172.16.13.0 0.0.0.255

network 192.168.3.0 0.0.0.255

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g0/0/0

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

interface g0/0/1

ip authentication mode eigrp 412 md5

ip authentication key-chain eigrp 412 security

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

D1 Configuration File Scripts

!D1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/4.1.2.1-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 4.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

spanning-tree mode rapid-pvst

spanning-tree vlan 1-2 root primary

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

switchport mode trunk

no shutdown

exit

interface g1/0/1

switchport mode access

switchport access vlan 1

no shutdown

exit

interface g1/0/23

switchport mode access

switchport access vlan 2

no shutdown

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!D1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/4.1.2.2-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 4.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

spanning-tree mode rapid-pvst

spanning-tree vlan 1-2 root primary

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

switchport mode trunk

no shutdown

exit

interface g1/0/1

switchport mode access

switchport access vlan 1

no shutdown

exit

interface g1/0/23

switchport mode access

switchport access vlan 2

no shutdown

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!D1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/4.1.2.3-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 4.1.2.3 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

spanning-tree mode rapid-pvst

spanning-tree vlan 1-2 root primary

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

switchport mode trunk

no shutdown

exit

interface g1/0/1

switchport mode access

switchport access vlan 1

no shutdown

exit

interface g1/0/23

switchport mode access

switchport access vlan 2

no shutdown

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

D2 Configuration File Scripts

!D2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/4.1.2.1-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 4.1.2.1 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

spanning-tree mode rapid-pvst

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

switchport mode access

switchport access vlan 1

no shutdown

exit

interface g1/0/1

switchport mode access

switchport access vlan 1

no shutdown

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!D2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/4.1.2.2-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 4.1.2.2 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

spanning-tree mode rapid-pvst

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

switchport mode access

switchport access vlan 1

no shutdown

exit

interface g1/0/1

switchport mode access

switchport access vlan 1

no shutdown

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

!D2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/4.1.2.3-d2-config.txt” w+ ] {

hostname D2

ip routing

banner motd # This is D2, Trouble Ticket 4.1.2.3 #

enable secret cisco12345

username admin privilege 15 algorithm-type scrypt secret cisco12345

spanning-tree mode rapid-pvst

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

no switchport

ip address 172.16.13.2 255.255.255.0

no shutdown

exit

interface g1/0/1

no switchport

ip address 172.16.1.2 255.255.255.0

no shutdown

exit

interface loopback 0

ip address 192.168.20.1 255.255.255.0

no shutdown

exit

interface loopback 1

ip address 192.168.21.1 255.255.255.0

no shutdown

exit

router eigrp 421

eigrp router-id 132.132.132.132

network 172.16.1.0 0.0.0.255

network 172.16.13.0 0.0.0.255

network 192.168.20.0 0.0.0.255

network 192.168.21.0 0.0.0.255

exit

key chain security

key 1

key-string cisco12345

exit

exit

interface g1/0/1

ip authentication mode eigrp 421 md5

ip authentication key-chain eigrp 421 security

exit

interface g1/0/11

ip authentication mode eigrp 421 md5

ip authentication key-chain eigrp 421 security

exit

line con 0

exec-timeout 0 0

logging synchronous

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

A1 Configuration File Scripts – Not Used In This Lab

0 0 vote
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments