5.2.3 Packet Tracer – Implement EIGRP for IPv4 and IPv6 Answers

Last Updated on February 27, 2021 by Admin

5.2.3 Packet Tracer – Implement EIGRP for IPv4 and IPv6 Answers

Packet Tracer – Implement EIGRP for IPv4 and IPv6 (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

IPv4 Addressing Table

Device

Interface

IPv4 Address

Subnet Mask

IPv4-Edge

S0/0/0

172.31.6.1

255.255.255.252

IPv4-Edge

S0/0/1

10.10.8.1

255.255.255.252

IPv4-Edge

S0/1/0

209.165.200.226

255.255.255.224

R1

S0/0/0

172.31.6.2

255.255.255.252

R1

Lo8

172.31.0.1

255.255.255.128

R1

Lo9

172.31.0.129

255.255.255.128

R1

Lo10

172.31.1.1

255.255.255.128

R1

Lo11

172.31.1.129

255.255.255.128

R2

S0/0/1

10.10.8.2

255.255.255.252

R2

Lo1

10.10.0.1

255.255.255.0

R2

Lo2

10.10.1.1

255.255.255.0

R2

Lo3

10.10.2.1

255.255.254.0

R2

Lo4

10.10.4.1

255.255.252.0

IPv4 Server

NIC

64.100.1.10

255.255.255.0

IPv6 Addressing Table

Device

Interface

IPv6 Address and Prefix Length

IPv6-Edge

S0/0/0

2001:DB8:A001:6::1/64

IPv6-Edge

S0/0/1

2001:DB8:A001:7::1/64

IPv6-Edge

S0/1/0

2001:DB8:CAFE:1::2/64

R3

S0/0/0

2001:DB8:A001:7::2/64

R4

S0/0/1

2001:DB8:A001:6::2/64

IPv6 Server

NIC

2001:DB8:CAFE:1000::A/64

Scenario

In this activity, you must implement EIGRP for IPv4 and IPv6 on two separate networks. Your task includes enabling EIGRP, assigning router IDs, changing the hello timers, and limiting EIGRP advertisements.

Instructions

Requirements

EIGRP for IPv4

Implement EIGRP on IPv4-enabled routers using Autonomous System 1.

  • Use a single classful network address to advertise the loopback interfaces.
  • Use the wildcard mask to advertise the /30 networks between R1, R2 and IPv4-Edge.
  • Use the default passive interface method and only allow EIGRP updates out the active EIGRP serial interfaces.

R1(config)# router eigrp 1

R1(config-router)# passive-interface default

R1(config-router)# no passive-interface Serial0/0/0

R1(config-router)# network 172.31.0.0

R2(config)# router eigrp 1

R2(config-router)# passive-interface default

R2(config-router)# no passive-interface Serial0/0/1

R2(config-router)# network 10.0.0.0

IPv4-Edge(config)# router eigrp 1

IPv4-Edge(config-router)# passive-interface default

IPv4-Edge(config-router)# no passive-interface Serial0/0/0

IPv4-Edge(config-router)# no passive-interface Serial0/0/1

IPv4-Edge(config-router)# network 172.31.6.0 0.0.0.3

IPv4-Edge(config-router)# network 10.10.8.0 0.0.0.3

  • Configure a directly attached default route on IPv4-Edge and propagate it in EIGRP updates.

IPv4-Edge(config)# ip route 0.0.0.0 0.0.0.0 Serial0/1/0

IPv4-Edge(config)# router eigrp 1

IPv4-Edge(config-router)# redistribute static

  • Configure the serial interfaces between R1, R2 and IPv4-Edge to send hellos every 10 seconds.

R1(config)# interface s0/0/0

R1(config-if)# ip hello-interval eigrp 1 10

R2(config)# interface s0/0/1

R2(config-if)# ip hello-interval eigrp 1 10

IPv4-Edge(config)# interface s0/0/0

IPv4-Edge(config-if)# ip hello-interval eigrp 1 10

IPv4-Edge(config-if)# interface s0/0/1

IPv4-Edge(config-if)# ip hello-interval eigrp 1 10

  • R1 and R2 should have a default route in the routing table (D*EX).
  • Verify R1 and R2 can ping the IPv4 Server. IPv4 Server should also be able to ping every loopback address on R1 and R2.

EIGRP for IPv6

  • Implement EIGRP for IPv6 on the IPv6-enabled routers using Autonomous System 1.
  • Assign IPv6-Edge with the router ID of 1.1.1.1
  • Assign R3 with the router ID of 3.3.3.3
  • Assign R4 with the router ID of 4.4.4.4

IPv6-Edge(config)# ipv6 unicast-routing

IPv6-Edge(config)# ipv6 router eigrp 1

IPv6-Edge(config-rtr)# eigrp router-id 1.1.1.1

IPv6-Edge(config-rtr)# no shutdown

IPv6-Edge(config-rtr)# interface Serial0/0/0

IPv6-Edge(config-if)# ipv6 eigrp 1

IPv6-Edge(config-if)# interface Serial0/0/1

IPv6-Edge(config-if)# ipv6 eigrp 1

R3(config)# ipv6 unicast-routing

R3(config)# ipv6 router eigrp 1

R3(config-rtr)# eigrp router-id 3.3.3.3

R3(config-rtr)# no shutdown

R3(config-rtr)# interface Loopback0

R3(config-if)# ipv6 eigrp 1

R3(config-if)# interface Loopback1

R3(config-if)# ipv6 eigrp 1

R3(config-if)# interface Loopback2

R3(config-if)# ipv6 eigrp 1

R3(config-if)# interface Loopback3

R3(config-if)# ipv6 eigrp 1

R3(config-if)# interface Serial0/0/0

R3(config-if)# ipv6 eigrp 1

R4(config)# ipv6 unicast-routing

R4(config)# ipv6 router eigrp 1

R4(config-rtr)# eigrp router-id 4.4.4.4

R4(config-rtr)# no shutdown

R4(config-rtr)# interface Loopback8

R4(config-if)# ipv6 eigrp 1

R4(config-if)# interface Loopback9

R4(config-if)# ipv6 eigrp 1

R4(config-if)# interface Loopback10

R4(config-if)# ipv6 eigrp 1

R4(config-if)# interface Loopback11

R4(config-if)# ipv6 eigrp 1

R4(config-if)# interface Serial0/0/1

R4(config-if)# ipv6 eigrp 1

  • Configure a directly attached default route on IPv6-Edge and propagate it in EIGRP updates.

IPv6-Edge(config)# ipv6 route ::/0 Serial0/1/0

IPv6-Edge(config)# ipv6 router eigrp 1

IPv6-Edge(config-rtr)# redistribute static

  • R3 and R4 should show a default external route in the routing table.
  • Verify R3 and R4 can ping the IPv6 Server. IPv6 Server should also be able to ping every loopback address on R3 and R4.

End of document

Answer Scripts

Router IPv4-Edge

enable

configure terminal

interface Serial0/0/0

ip hello-interval eigrp 1 10

interface Serial0/0/1

ip hello-interval eigrp 1 10

router eigrp 1

redistribute static

passive-interface default

no passive-interface Serial0/0/0

no passive-interface Serial0/0/1

network 172.31.6.0 0.0.0.3

network 10.10.8.0 0.0.0.3

ip route 0.0.0.0 0.0.0.0 Serial0/1/0

end

Router R1

enable

configure terminal

interface Serial0/0/0

ip hello-interval eigrp 1 10

router eigrp 1

passive-interface default

no passive-interface Serial0/0/0

network 172.31.0.0

end

Router R2

enable

configure terminal

interface Serial0/0/1

ip hello-interval eigrp 1 10

router eigrp 1

passive-interface default

no passive-interface Serial0/0/1

network 10.0.0.0

end

Router IPv6-Edge

enable

configure terminal

ipv6 unicast-routing

interface Serial0/0/0

ipv6 eigrp 1

interface Serial0/0/1

ipv6 eigrp 1

ipv6 router eigrp 1

eigrp router-id 1.1.1.1

no shutdown

redistribute static

ipv6 route ::/0 Serial0/1/0

end

Router R3

enable

configure terminal

ipv6 unicast-routing

interface Loopback0

ipv6 eigrp 1

interface Loopback1

ipv6 eigrp 1

interface Loopback2

ipv6 eigrp 1

interface Loopback3

ipv6 eigrp 1

interface Serial0/0/0

ipv6 eigrp 1

ipv6 router eigrp 1

eigrp router-id 3.3.3.3

no shutdown

end

Router R4

enable

configure terminal

ipv6 unicast-routing

interface Loopback8

ipv6 eigrp 1

interface Loopback9

ipv6 eigrp 1

interface Loopback10

ipv6 eigrp 1

interface Loopback11

ipv6 eigrp 1

interface Serial0/0/1

ipv6 eigrp 1

ipv6 router eigrp 1

eigrp router-id 4.4.4.4

no shutdown

end

0 0 vote
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments