8.1.2 Lab – Troubleshoot OSPFv2 Answers

Last Updated on February 27, 2021 by Admin

8.1.2 Lab – Troubleshoot OSPFv2 Answers

Lab – Troubleshoot OSPFv2 (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

This topology has 3 routers, 2 switches and a PC. R2 G0/0/0 is connected to R1 G0/0/0. R1 G0/0/1 is connected D1 G1/0/11. D1 G1/0/1 is connected to D2 G1/0/1. D1 G1/0/2 is connected to D2 G1/0/2. D1 G1/0/3 is connected to D2 G1/0/3. D1 G1/0/4 is connected to D2 G1/0/4. D2 G1/0/11 is connected R3 G0/0/1. PC1 is connected to D1 G1/0/24.

Addressing Table

Device

Interface

IPv4 Address

Subnet Mask

R1

G0/0/0

10.2.0.1

255.255.255.0

R1

G0/0/1

10.0.1.1

255.255.255.0

R2

G0/0/0

10.2.0.2

255.255.255.0

R2

Lo1

10.2.1.1

255.255.255.0

R3

G0/0/1

10.0.3.1

255.255.255.0

R3

Lo1

10.3.1.1

255.255.255.0

D1

G1/0/1 (Po1)

10.0.2.1

255.255.255.0

D1

G1/0/2 (Po1)

10.0.2.1

255.255.255.0

D1

G1/0/3 (Po2)

10.1.1.1

255.255.255.0

D1

G1/0/4 (Po2)

10.1.1.1

255.255.255.0

D1

G1/0/11

10.0.1.2

255.255.255.0

D1

G1/0/23

10.1.2.1

255.255.255.0

D1

G1/0/24

10.1.3.1

255.255.255.0

D2

G1/0/1 (Po1)

10.0.2.2

255.255.255.0

D2

G1/0/2 (Po1)

10.0.2.2

255.255.255.0

D2

G1/0/3 (Po2)

10.1.1.2

255.255.255.0

D2

G1/0/4 (Po2)

10.1.1.2

255.255.255.0

D2

G1/0/11

10.0.3.2

255.255.255.0

PC1

NIC

10.1.3.100/24

Default Gateway 10.1.3.1

Objectives

Troubleshoot network issues related to the configuration and operation of OSPFv2.

Background / Scenario

Your University network is using multiarea OSPFv2. The 10.3.1.0/24 network has a single end device which connects to an observatory. Reading the network design documentation, you notice two key items regarding this connection:

  • The connection from R3 to the observatory is a microwave link. Because this link can be unstable, it is required to be in its own OSPFv2 area.
  • The data from the observatory is sent to an astronomy research team on the 10.1.3.0/24 network (PC1).

Although the topology has a limited number of routers, you should use the appropriate troubleshooting commands to help find and solve the problems in the three trouble tickets as if this were a much more complex topology with many more routers and networks.

You will be loading configurations with intentional errors onto the network. Your tasks are to FIND the error(s), document your findings and the command(s) or method(s) used to fix them, FIX the issue(s) presented here and then test the network to ensure both of the following conditions are met:

1)the complaint received in the ticket is resolved

2)full reachability is restored

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release 16.9.4 (universalk9 image) and Cisco Catalyst 2960s with Cisco IOS Release 15.2(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3560 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (choice of operating system with terminal emulation program installed)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1:Trouble Ticket 8.1.2.1

Scenario:

Changes were made to minimize the number of routes in area 2. The intention was that all internal OSPF routers in area 2 would only receive a default route via OSPF, and they would not receive any interarea OSPF routes. However, after the change was made users began to indicate that they no longer have connectivity to devices on the 10.2.1.0/24 network.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for uploading the configuration are provided at the end of this document.

Device

Command

R1

copy flash:/enarsi/8.1.2.1-r1-config.txt run

R2

copy flash:/enarsi/8.1.2.1-r2-config.txt run

R3

copy flash:/enarsi/8.1.2.1-r3-config.txt run

D1

copy flash:/enarsi/8.1.2.1-d1-config.txt run

D2

copy flash:/enarsi/8.1.2.1-d2-config.txt run

  • All routers should have the 10.2.1.0/24 network in their routing tables.
  • All area 2 internal OSPF routers should only receive a default route via OSPF, they should not have any interarea routes.
  • PC1 should be able to ping 10.2.1.1/24.
  • R3, D1, and D2 should see the 10.2.1.0/24 network in their routing table.
  • R2 should only have a single OSPF route in its routing table, and that should be a default route learned via OSPF.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 2 intentional errors:

1)R1: OSPF area 2 is configured as a stub area instead of a totally stubby area.

2)R2: OSPF area 2 is configured as a normal area.

The commands used to fix these errors should be:

R1(config)# router ospf 1

R1(config-router)# no area 2 stub

R1(config-router)# area 2 stub no-summary

R2(config)# router ospf 1

R2(config-router)# area 2 stub

Part 2:Trouble Ticket 8.1.2.2

Scenario:

Recently Layer 3 switch D2 was replaced. However, the backup config file was corrupt and unable to be used. One of the network technicians configured D2 manually using the network documentation including the topology. After D2 was brought online, D2’s routing table only sees the 10.3.1.0/24 network via OSPF.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/8.1.2.2-r1-config.txt run

R2

copy flash:/enarsi/8.1.2.2-r2-config.txt run

R3

copy flash:/enarsi/8.1.2.2-r3-config.txt run

D1

copy flash:/enarsi/8.1.2.2-d1-config.txt run

D2

copy flash:/enarsi/8.1.2.2-d2-config.txt run

  • D2 should see all OSPF networks.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 2 intentional errors. D2 has the wrong subnet mask on both port-channel 1 and port-channel 2. This prohibited D2 from forming an OSPF adjacency with D1. Port-channel 1 on D2 does not have an IP address because it had the wrong subnet mask that caused it to overlap the G1/0/11 interface. This creates overlapping subnets causing port-channel 1 to be shutdown. Port-channel 2 was also configured the wrong subnet mask.

The commands used to fix these errors should be:

D2(config)# interface port-channel 1

D2(config-if)# ip address 10.0.2.2 255.255.255.0

D2(config-if)# no shutdown

D2(config-if)# exit

D2(config)# interface port-channel 2

D2(config-if)# ip address 10.1.1.2 255.255.255.0

D2(config-if)# no shutdown

Note: The no shutdown command will be required on at least one interface.

Part 3:Trouble Ticket 8.1.2.3

Topology Update:

This topology has 3 routers, 2 switches and a PC. R2 G0/0/0 is connected to R1 G0/0/0. R1 G0/0/1 is connected D1 G1/0/11. D1 G1/0/1 is connected to D2 G1/0/1. D1 G1/0/2 is connected to D2 G1/0/2. D1 G1/0/3 is connected to D2 G1/0/3. D1 G1/0/4 is connected to D2 G1/0/4. D2 G1/0/11 is connected R3 G0/0/1. R3 G0/0/0 is connected to R2 G0/0/1.

Addressing Table Update:

Device

Interface

IPv4 Address

Subnet Mask

R2

G0/0/0

10.2.0.2

255.255.255.0

R2

G0/0/1

10.3.0.2

255.255.255.0

R2

Lo1

10.2.1.1

255.255.255.0

R3

G0/0/0

10.3.0.1

255.255.255.0

R3

G0/0/1

10.0.3.1

255.255.255.0

R3

Lo1

10.3.1.1

255.255.255.0

Scenario:

The 10.3.1.0/24 network has a single end device which connects to an observatory. Reading the network design documentation, you notice three key items:

  • The connection from R3 to the observatory is a microwave link. Because this link can be unstable, it is required to be in its own OSPFv2 area. The data from the observatory is sent to an astronomy research team on the 10.1.3.0/24 network (PC5).
  • For redundancy purposes the design team had installed a new link between R2 and R3. This link results in an additional path from R1 to PC5. The primary path is through D2 to R3. The new backup path is through R2 to R3. This is verified using traceroute.
  • Although redundancy is helpful, the most important requirement is that 101.3.0/24 is in its own OSPF area.

A troubleshooting ticket has just been received by the help desk. During construction of a new building on campus, the link between R3 and D2 was cut. It may take four or five days before this link can be restored.

The astronomy team has informed your manager that they are not receiving the data from the observatory and they cannot wait more than a day for the data from the observatory. Your manager is confused about why the data is not being forwarded using the redundant connection via R2.

Your task is to diagnose this problem and resolve it. Connectivity between the 10.3.1.0/24 and 10.1.3.0/24 networks is critical. In addition, the 10.3.1.0/24 network must be in its own area so the unstable link does not affect other areas.

Note: OSPF area 2 and area 3 are both normal OSPF areas.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/8.1.2.3-r1-config.txt run

R2

copy flash:/enarsi/8.1.2.3-r2-config.txt run

R3

copy flash:/enarsi/8.1.2.3-r3-config.txt run

D1

copy flash:/enarsi/8.1.2.3-d1-config.txt run

D2

copy flash:/enarsi/8.1.2.3-d2-config.txt run

Note: To simulate the link being cut, shut down the G0/0/1 interface on R3:

R3(config)# inter g 0/0/1

R3(config-if)# shutdown

  • PC1 should be able to ping the 10.3.1.1.
  • Network 10.3.1.0/24 must be in its own area.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains a design error. ABR R2 belongs to two areas, area 2 and area 3. The OSPF specification states that an ABR is restricted to considering LSA 3s only from the backbone area (area 0) to avoid routing loops. After the link between R3 and D2 went down, the networks in area 3 were no longer reachable via OSPF from other areas. R2 will not be propagating LSA 3s from area 3 (a nonbackbone area) into area 2.

A virtual link will need to be created between R1 and R2 to restore connectivity.

The commands used to fix these errors should be:

R1(config)# router ospf 1

R1(config-router)# area 2 virtual-link 2.2.2.2

R2(config)# router ospf 1

R2(config-router)# area 2 virtual-link 1.1.1.1

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Uploading Configuration Files

Use the commands below to create the configuration files for each trouble ticket in this lab on the lab devices. The TCL script commands help create and copy the configurations. However, the configuration commands could also be copied and pasted directly into global config mode on each device. Simply remove the TCL script commands, enter the enable and configure t commands on the device, and copy and paste the configuration commands.

Important: The device requires a folder in flash named enarsi. Use the dir command to verify. If the folder is missing, then create it using the mkdir flash:/enarsi privileged exec command. For all switches, make sure the vlan.dat file is set to the default. Use the delete vlan.dat privileged EXEC command, if necessary.

Reset scripts

These TCL scripts will completely clear and reload the device in preparation for the next ticket. Copy and paste the appropriate script to the appropriate device.

Router Reset Script

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

puts “Reloading the router”

typeahead “\n”

reload

}

tclquit

D1/D2 (Cisco 3650) Reset Script – The default 3650 SDM template supports IPv6 by default, so it is not set by this script.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

puts “Reloading the switch”

typeahead “\n”

reload

}

tclquit

A1 (Cisco 2960 Script) – The default 2960 SDM template does not support IPv6, so this script includes that setting.

tclsh

puts [ open “flash:reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

delete /force multiple-fs

ios_configsdm prefer lanbase-routing”

typeahead “\n”

puts “Reloading the switch in 1 minute, type reload cancel to halt”

typeahead “\n”

reload

}

tclquit

R1 Configuration File Scripts

!R1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/8.1.2.1-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 8.1.2.1 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.2.0.1 255.255.255.0

no shut

inter g 0/0/1

ip add 10.0.1.1 255.255.255.0

no shut

int lo0

ip add 64.100.10.1 255.255.255.0

router ospf 1

router-id 1.1.1.1

network 10.0.1.0 0.0.0.255 area 0

network 10.2.0.0 0.0.0.255 area 2

default-information originate always

area 2 stub

exit

ip route 0.0.0.0 0.0.0.0 lo0

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/8.1.2.2-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 8.1.2.2 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.2.0.1 255.255.255.0

no shut

inter g 0/0/1

ip add 10.0.1.1 255.255.255.0

no shut

int lo0

ip add 64.100.10.1 255.255.255.0

router ospf 1

router-id 1.1.1.1

network 10.0.1.0 0.0.0.255 area 0

network 10.2.0.0 0.0.0.255 area 2

default-information originate always

area 2 stub no-summary

exit

ip route 0.0.0.0 0.0.0.0 lo0

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/8.1.2.3-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 8.1.2.3 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.2.0.1 255.255.255.0

no shut

inter g 0/0/1

ip add 10.0.1.1 255.255.255.0

no shut

int lo0

ip add 64.100.10.1 255.255.255.0

router ospf 1

router-id 1.1.1.1

network 10.0.1.0 0.0.0.255 area 0

network 10.2.0.0 0.0.0.255 area 2

default-information originate always

exit

ip route 0.0.0.0 0.0.0.0 lo0

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

R2 Configuration File Scripts

!R2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/8.1.2.1-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 8.1.2.1 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.2.0.2 255.255.255.0

no shut

inter lo 0

ip add 10.2.1.1 255.255.255.0

ip ospf network point-to-point

no shut

router ospf 1

router-id 2.2.2.2

network 10.2.1.0 0.0.0.255 area 2

network 10.2.0.0 0.0.0.255 area 2

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/8.1.2.2-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 8.1.2.2 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.2.0.2 255.255.255.0

no shut

inter lo 0

ip add 10.2.1.1 255.255.255.0

ip ospf network point-to-point

no shut

router ospf 1

router-id 2.2.2.2

network 10.2.1.0 0.0.0.255 area 2

network 10.2.0.0 0.0.0.255 area 2

area 2 stub

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/8.1.2.3-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 8.1.2.3 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.2.0.2 255.255.255.0

no shut

inter g 0/0/1

ip add 10.3.0.2 255.255.255.0

no shut

inter lo 0

ip add 10.2.1.1 255.255.255.0

ip ospf network point-to-point

no shut

router ospf 1

router-id 2.2.2.2

network 10.2.1.0 0.0.0.255 area 2

network 10.2.0.0 0.0.0.255 area 2

network 10.3.0.0 0.0.0.255 area 3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

R3 Configuration File Scripts

!R3 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/8.1.2.1-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 8.1.2.1 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/1

ip add 10.0.3.1 255.255.255.0

no shut

inter lo 0

ip add 10.3.1.1 255.255.255.0

ip ospf network point-to-point

no shut

router ospf 1

router-id 3.3.3.3

network 10.0.3.0 0.0.0.255 area 0

network 10.3.1.0 0.0.0.255 area 3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R3 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/8.1.2.2-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 8.1.2.2 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/1

ip add 10.0.3.1 255.255.255.0

no shut

inter lo 0

ip add 10.3.1.1 255.255.255.0

ip ospf network point-to-point

no shut

router ospf 1

router-id 3.3.3.3

network 10.0.3.0 0.0.0.255 area 0

network 10.3.1.0 0.0.0.255 area 3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!R3 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/8.1.2.3-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 8.1.2.3 #

no ip domain lookup

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ip add 10.3.0.1 255.255.255.0

no shut

inter g 0/0/1

ip add 10.0.3.1 255.255.255.0

no shut

inter lo 0

ip add 10.3.1.1 255.255.255.0

ip ospf network point-to-point

no shut

router ospf 1

router-id 3.3.3.3

network 10.0.3.0 0.0.0.255 area 0

network 10.3.0.0 0.0.0.255 area 3

network 10.3.1.0 0.0.0.255 area 3

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

D1 Configuration File Scripts

!D1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/8.1.2.1-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 8.1.2.1 #

no ip domain lookup

ip routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ip add 10.0.1.2 255.255.255.0

no shut

exit

inter g 1/0/23

no switchport

ip add 10.1.2.1 255.255.255.0

no shut

exit

inter g 1/0/24

no switchport

ip add 10.1.3.1 255.255.255.0

no shut

exit

interface g 1/0/1

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/2

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/3

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

interface g 1/0/4

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

inter port-channel 1

ip add 10.0.2.1 255.255.255.0

no shut

exit

inter port-channel 2

ip add 10.1.1.1 255.255.255.0

no shut

exit

inter range g1/0/5-10, g1/0/12-22

shut

router ospf 1

router-id 4.4.4.4

network 10.0.1.0 0.0.0.255 area 0

network 10.0.2.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 1

network 10.1.2.0 0.0.0.255 area 1

network 10.1.3.0 0.0.0.255 area 1

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/8.1.2.2-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 8.1.2.2 #

hostname D1

no ip domain lookup

ip routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ip add 10.0.1.2 255.255.255.0

no shut

exit

inter g 1/0/23

no switchport

ip add 10.1.2.1 255.255.255.0

no shut

exit

inter g 1/0/24

no switchport

ip add 10.1.3.1 255.255.255.0

no shut

exit

interface g 1/0/1

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/2

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/3

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

interface g 1/0/4

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

inter port-channel 1

ip add 10.0.2.1 255.255.255.0

no shut

exit

inter port-channel 2

ip add 10.1.1.1 255.255.255.0

no shut

exit

inter range g1/0/5-10, g1/0/12-22

shut

router ospf 1

router-id 4.4.4.4

network 10.0.1.0 0.0.0.255 area 0

network 10.0.2.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 1

network 10.1.2.0 0.0.0.255 area 1

network 10.1.3.0 0.0.0.255 area 1

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/8.1.2.3-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 8.1.2.3 #

no ip domain lookup

ip routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ip add 10.0.1.2 255.255.255.0

no shut

exit

inter g 1/0/23

no switchport

ip add 10.1.2.1 255.255.255.0

no shut

exit

inter g 1/0/24

no switchport

ip add 10.1.3.1 255.255.255.0

no shut

exit

interface g 1/0/1

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/2

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/3

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

interface g 1/0/4

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

inter port-channel 1

ip add 10.0.2.1 255.255.255.0

no shut

exit

inter port-channel 2

ip add 10.1.1.1 255.255.255.0

no shut

exit

inter range g1/0/5-10, g1/0/12-22

shut

router ospf 1

router-id 4.4.4.4

network 10.0.1.0 0.0.0.255 area 0

network 10.0.2.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 1

network 10.1.2.0 0.0.0.255 area 1

network 10.1.3.0 0.0.0.255 area 1

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

D2 Configuration File Scripts

!D2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/8.1.2.1-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 8.1.2.1 #

no ip domain lookup

ip routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ip add 10.0.3.2 255.255.255.0

no shut

interface g 1/0/1

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/2

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/3

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

interface g 1/0/4

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

inter port-channel 1

ip add 10.0.2.2 255.255.255.0

no shut

inter port-channel 2

ip add 10.1.1.2 255.255.255.0

no shut

inter range g1/0/5-10, g1/0/12-24

shut

router ospf 1

router-id 5.5.5.5

network 10.0.2.0 0.0.0.255 area 0

network 10.0.3.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 1

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/8.1.2.2-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 8.1.2.2 #

no ip domain lookup

ip routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ip add 10.0.3.2 255.255.255.0

no shut

interface g 1/0/1

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/2

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/3

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

interface g 1/0/4

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

inter port-channel 1

ip add 10.0.2.2 255.255.0.0

no shut

inter port-channel 2

ip add 10.1.1.2 255.255.0.0

no shut

inter range g1/0/5-10, g1/0/12-24

shut

router ospf 1

router-id 5.5.5.5

network 10.0.2.0 0.0.0.255 area 0

network 10.0.3.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 1

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

!D2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/8.1.2.3-d2-config.txt” w+ ] {

hostname D2

ip routing

banner motd # This is D2, Trouble Ticket 8.1.2.3 #

no ip domain lookup

ip routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ip add 10.0.3.2 255.255.255.0

no shut

interface g 1/0/1

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/2

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/3

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

interface g 1/0/4

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

inter port-channel 1

ip add 10.0.2.2 255.255.255.0

no shut

inter port-channel 2

ip add 10.1.1.2 255.255.255.0

no shut

inter range g1/0/5-10, g1/0/12-24

shut

router ospf 1

router-id 5.5.5.5

network 10.0.2.0 0.0.0.255 area 0

network 10.0.3.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 1

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

clear ip ospf process

yes

}

tclquit

A1 Configuration File Scripts – Not Used In This Lab

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments