• Post author:
  • Post category:Blog
  • Reading time:150 mins read
  • Post last modified:June 12, 2024

1.1.2 Lab – Implement Inter-VLAN Routing Answers

Lab – Implement Inter-VLAN Routing (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

This topology has 2 routers, 2 switches, 4 PCs. PC-1 is connected to E23 on switch D1 and PC-2 is connected to D2 E24. D1 E11 is connected to router R1 via E1. Serial s0/1/1 is connected to router R3 Serial s0/1/1. Router R3 E0/1 is connected to D2 E11. PC-3 is connected to D2 E23 and PC-4 is connected to D2 E24.

Addressing Table

Device

Interface

IPv4 Address

IPv6 Address

IPv6 Link-Local

R1

G0/0/1

10.1.13.1/24

2001:db8:acad:10d1::1/64

fe80::1:1

R1

S0/1/1

10.1.3.1/24

2001:db8:acad:1013::1/64

fe80::1:2

D1

G1/0/11

10.1.13.13/24

2001:db8:acad:10d1::d1/64

fe80::d1:1

D1

VLAN50

10.2.50.1/24

2001:db8:acad:1050::d1/64

fe80::d1:2

D1

VLAN60

10.2.60.1/24

2001:db8:acad:1060::d1/64

fe80::d1:3

R3

S0/1/1

10.1.3.3/24

2001:db8:acad:1013::3/64

fe80::3:1

R3

G0/0/1.75

10.3.75.1/24

2001:db8:acad:3075::1/64

fe80::3:2

R3

G0/0/1.85

10.3.85.1/24

2001:db8:acad:3085::1/64

fe80::3:3

D2

VLAN75

10.3.75.14/24

2001:db8:acad:3075::d2/64

fe80::d2:1

PC1

NIC

10.2.50.50/24

2001:db8:acad:1050::50/64

EUI-64

PC2

NIC

10.2.60.50/24

2001:db8:acad:1060::50/64

EUI-64

PC3

NIC

10.3.75.50/24

2001:db8:acad:3075::50/64

EUI-64

PC4

NIC

10.3.85.50/24

2001:db8:acad:3085::50/64

EUI-64

Objectives

Part 1: Build the Network and Configure Basic Device Settings

Part 2: Configure and Verify Inter-VLAN Routing on a Layer 3 Switch

Part 3: Configure and Verify Router-based Inter-VLAN Routing

Part 4: Examine CAM and CEF Details

Background / Scenario

The methods used to move packets and frames from one interface to the next has changed over the years. In this lab you will configure Inter-VLAN Routing in its various forms and then examine the different tables used in making forwarding decisions.

Note: This lab is an exercise in configuring and verifying various methods of Inter-VLAN routing and does not reflect networking best practices.

Note: The routers and switches used with CCNP hands-on labs are Cisco 4221 and Cisco 3650, both with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs.

Note: Ensure that the routers and switches have been erased and have no startup configurations. If you are unsure contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 2 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3650 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 4 PCs (PC with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Instructions

Part 1:  Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings.

Step 1:  Cable the network as shown in the topology.

Attach the devices as shown in the topology diagram, and cable as necessary.

Step 2:  Configure basic settings for each device.

  1. Console into each router, enter global configuration mode, and apply the basic settings using the following startup configurations.

Open configuration window

Router R1

no ip domain lookup

hostname R1

line con 0

 exec-timeout 0 0

 logging synchronous

 exit

banner motd # This is R1, Inter-VLAN Routing Lab #

Router R3

no ip domain lookup

hostname R3

line con 0

 exec-timeout 0 0

 logging synchronous

 exit

banner motd # This is R3, Inter-VLAN Routing Lab #

Switch D1

no ip domain lookup

hostname D1

line con 0

 exec-timeout 0 0

 logging synchronous

 exit

banner motd # This is D1, Inter-VLAN Routing Lab #

interface range g1/0/1-24, g0/0, g1/1/1-4

 shutdown

Switch D2

no ip domain lookup

hostname D2

line con 0

 exec-timeout 0 0

 logging synchronous

 exit

banner motd # This is D2, Inter-VLAN Routing Lab #

interface range g1/0/1-24, g0/0, g1/1/1-4

 shutdown

  1. Set the clock on each device to UTC time.
  2. Save the running configuration to startup-config.

Close configuration window

Part 2:  Configure and Verify Inter-VLAN Routing on a Layer 3 Switch

In Part 2, you will configure and verify inter-VLAN Routing on a Layer 3 switch. For this part, you will focus on the configuration of switch D1 and router R1.

Note: The default Switch Database Manager (SDM) template on a Catalyst 3650 running IOS XE supports dual-stacked operations and requires no additional configuration for our purposes.

If you are using an alternate device running Cisco IOS, check the SDM template with the privileged EXEC command show sdm prefer and verify that the ‘number of IPv6 unicast routes’ supported is not zero.

If it is zero, you must change the SDM template to one that supports IPv6 using the sdm prefer template_name global configuration command. The template name will vary depending on the IOS version. Changing the template will require a reboot.

Step 1:  On D1, configure Inter-VLAN Routing.

Open configuration window

  1. Configure D1 to support IP routing and IPv6 unicast routing.

D1(config)# ip routing

D1(config)# ipv6 unicast-routing

  1. Create the VLANs and name them as specified in the topology.

D1(config)# vlan 50

D1(config-vlan)# name Group50

D1(config-vlan)# exit

D1(config)# vlan 60

D1(config-vlan)# name Group60

D1(config-vlan)# exit

  1. Assign the G1/0/23 to VLAN 50 and G1/0/24 to VLAN 60.

D1(config)# interface g1/0/23

D1(config-if)# switchport mode access

D1(config-if)# switchport access vlan 50

D1(config-if)# no shutdown

D1(config-if)# exit

D1(config)# interface g1/0/24

D1(config-if)# switchport mode access

D1(config-if)# switchport access vlan 60

D1(config-if)# no shutdown

D1(config-if)# exit

  1. Create the Switched Virtual Interfaces (SVI) that will support VLAN 50 and VLAN 60.

D1(config)# interface vlan 50

D1(config-if)# ip address 10.2.50.1 255.255.255.0

D1(config-if)# ipv6 address fe80::d1:2 link-local

D1(config-if)# ipv6 address 2001:db8:acad:1050::d1/64

D1(config-if)# no shutdown

D1(config-if)# exit

D1(config)# interface vlan 60

D1(config-if)# ip address 10.2.60.1 255.255.255.0

D1(config-if)# ipv6 address fe80::d1:3 link-local

D1(config-if)# ipv6 address 2001:db8:acad:1060::d1/64

D1(config-if)# no shutdown

D1(config-if)# exit

  1. Configure PC1 with the addresses specified in the Addressing Table. Further assign default gateways of 10.2.50.1 and 2001:db8:acad:1050::d1.
  2. Configure PC2 with the addresses specified in the Addressing Table. Further assign default gateways of 10.2.60.1 and 2001:db8:acad:1060::d1.
  3. From PC1, ping PC2’s IPv4 and IPv6 address. Success indicates that D1 is performing Inter-VLAN Routing.
  4. Examine the MAC address table on D1 with the command show mac address-table dynamic. You should see PC1 and PC2’s mac addresses listed with the ports they are connected to.

D1# show mac address-table dynamic

          Mac Address Table

——————————————-

 

Vlan    Mac Address       Type        Ports

—-    ———–       ——–    —–

  50    0050.56b3.8137    DYNAMIC     Gi1/0/23

  60    0050.56b3.994b    DYNAMIC     Gi1/0/24

Total Mac Addresses for this criterion: 2

Step 2:  On D1, configure a routed port and default routes towards R1

  1. Configure interface G1/0/11 as a routed port with addressing as specified in the topology diagram.

D1(config)# interface g1/0/11

D1(config-if)# no switchport

D1(config-if)# ip address 10.1.13.13 255.255.255.0

D1(config-if)# ipv6 address fe80::d1:1 link-local

D1(config-if)# ipv6 address 2001:db8:acad:10d1::d1/64

D1(config-if)# no shutdown

D1(config-if)# exit

  1. Verify that interface G1/0/11 is no longer associated with the VLAN database by issuing the command show vlan brief | i g1/0/11. There should be no output.
  2. Configure static default routes for IPv4 and IPv6 that point towards the interface address at R1.

D1(config)# ip route 0.0.0.0 0.0.0.0 10.1.13.1

D1(config)# ipv6 route ::/0 2001:db8:acad:10d1::1

You may see the error message %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.1.13.1. This indicates that the switch sent an ARP for the MAC address of 10.1.13.1 and got no reply. We will configure that next.

Close configuration window

Step 3:  On R1, configure interface addressing and static routing.

Open configuration window

  1. Configure R1 to support IPv6 unicast routing.

R1(config)# ipv6 unicast-routing

  1. Configure the interfaces on R1 with the addresses specified in the Addressing Table.

R1(config)# interface g0/0/1

R1(config-if)# ip address 10.1.13.1 255.255.255.0

R1(config-if)# ipv6 address fe80::1:1 link-local

R1(config-if)# ipv6 address 2001:db8:acad:10d1::1/64

R1(config-if)# no shutdown

R1(config-if)# exit

R1(config)# interface s0/1/1

R1(config-if)# ip address 10.1.3.1 255.255.255.0

R1(config-if)# ipv6 address fe80::1:2 link-local

R1(config-if)# ipv6 address 2001:db8:acad:1013::1/64

R1(config-if)# no shutdown

R1(config-if)# exit

  1. Configure routing on R1. Configure static routes to the networks supported by D1 and a default route for everything else point at R3.

R1(config)# ip route 10.2.0.0 255.255.0.0 10.1.13.13

R1(config)# ipv6 route 2001:db8:acad:1050::/64 2001:db8:acad:10d1::d1

R1(config)# ipv6 route 2001:db8:acad:1060::/64 2001:db8:acad:10d1::d1

R1(config)#

R1(config)# ip route 0.0.0.0 0.0.0.0 10.1.3.3

R1(config)# ipv6 route ::/0 2001:db8:acad:1013::3

R1(config)#

  1. From R1, ping PC2 with IPv4 and IPv6. All pings should be successful.

Close configuration window

Part 3:  Configure and Verify Router-based Inter-VLAN Routing

Note: The default Switch Database Manager (SDM) template on a Catalyst 3650 running IOS XE supports dual-stacked operations and requires no additional configuration for our purposes.

If you are using an alternate device running Cisco IOS, check the SDM template with the privileged exec command show sdm prefer and verify that the ‘number of IPv6 unicast routes’ supported is not zero.

If it is zero, you must change the SDM template to one that supports IPv6 using the sdm prefer template_name global configuration command. The template name will vary depending on the IOS version. Changing the template will require a reboot.

Step 1:  Configure D2 to support the required VLANs.

  1. Create the VLANs and name them as specified in the topology. In addition, create vlan 999 and name it NativeVLAN.

Open configuration window

D2(config)# vlan 75

D2(config-vlan)# name Group75

D2(config-vlan)# exit

D2(config)# vlan 85

D2(config-vlan)# name Group85

D2(config-vlan)# exit

D2(config)# vlan 999

D2(config-vlan)# name NativeVLAN

D2(config-vlan)# exit

  1. Assign the G1/0/23 to VLAN 75 and G1/0/24 to VLAN 85.
  2. Create a Switched Virtual Interface that will operate within VLAN 75.

D2(config)# interface vlan75

D2(config-if)# ip address 10.3.75.14 255.255.255.0

D2(config-if)# ipv6 address fe80::d2:1 link-local

D2(config-if)# ipv6 address 2001:db8:acad:3075::d2/64

D2(config-if)# no shutdown

D2(config-if)# exit

  1. Create an IEEE 802.1Q-based trunk to R3. As a part of the configuration of the trunk, set the native VLAN to VLAN 999 and filter the VLANs allowed on the trunk down to only those that are configured.

D2(config)# interface g1/0/11

D2(config-if)# switchport mode trunk

D2(config-if)# switchport trunk native vlan 999

D2(config-if)# switchport trunk allowed vlan 75,85,999

D2(config-if)# no shutdown

D2(config-if)# exit

Close configuration window

Step 2:  Configure R3 to support Inter-VLAN Routing.

  1. Configure R3 to support IPv6 unicast routing.
  2. Configure the subinterfaces needed on R3 interface G0/0/1 to support the configured VLANs. Ensure an interface is created for the native VLAN 999.

Open configuration window

R3(config)# interface g0/0/1

R3(config-if)# no shutdown

R3(config-if)# exit

R3(config)# interface g0/0/1.75

R3(config-subif)# encapsulation dot1q 75

R3(config-subif)# ip address 10.3.75.1 255.255.255.0

R3(config-subif)# ipv6 address fe80::3:2 link-local

R3(config-subif)# ipv6 address 2001:db8:acad:3075::1/64

R3(config-subif)# no shutdown

R3(config-subif)# exit

R3(config)# interface g0/0/1.85

R3(config-subif)# encapsulation dot1q 85

R3(config-subif)# ip address 10.3.85.1 255.255.255.0

R3(config-subif)# ipv6 address fe80::3:3 link-local

R3(config-subif)# ipv6 address 2001:db8:acad:3085::1/64

R3(config-subif)# no shutdown

R3(config-subif)# exit

R3(config)# interface g0/0/1.999

R3(config-subif)# encapsulation dot1q 999 native

R3(config-subif)# no shutdown

R3(config-subif)# exit

  1. Configure PC3 with the addresses specified in the Addressing Table. Further assign default gateways of 10.3.75.1 and 2001:db8:acad:3075::1.
  2. Configure PC4 with the addresses specified in the Addressing Table. Further assign default gateways of 10.3.85.1 and 2001:db8:acad:3085::1.
  3. From PC3, ping PC4’s IPv4 and IPv6 address. Success indicates that R3 is performing Inter-VLAN Routing.

Step 3:  Configure static routing to enable end-to-end reachability.

  1. On R3, configure interface S0/1/1 with the addresses specified in the Addressing Table.

R3(config)# interface s0/1/1

R3(config-if)# ip address 10.1.3.3 255.255.255.0

R3(config-if)# ipv6 address fe80::3:1 link-local

R3(config-if)# ipv6 address 2001:db8:acad:1013::3/64

R3(config-if)# no shutdown

R3(config-if)# exit

  1. On R3, configure a static default route for IPv4 and IPv6 that points to R1’s S0/1/1 interface addresses.

R3(config)# ip route 0.0.0.0 0.0.0.0 10.1.3.1

R3(config)# ipv6 route ::/0 2001:db8:acad:1013::1

Close configuration window

  1. On PC3, issue a ping to PC2. The ping should be successful. This indicates the routing solution is working in both directions.

Part 4:  Examine CAM and CEF Details

In Part 4, you will examine CEF details on the devices you have configured. The objective of Cisco Express Forwarding is to speed up the process of moving data from one interface to another. To do this, as much data as possible is precompiled into two tables, the Forwarding Information Base (FIB) and the Adjacency Table. These are basically shortcuts that identify what interface a packet should be sent out of and how it should be framed.

  1. Issue the command show ip cef to see the compiled CEF table, which tells the device what to do with a frame or packet based on its destination address. This table gives the device a quick answer and keeps the CPU from getting directly involved. For example, packets destined to the 10.2.0.0/16 network are quickly resolved to the next-hop address of 10.1.13.13 exiting interface g0/0/1.

Open configuration window

R1# show ip cef

Prefix               Next Hop             Interface

0.0.0.0/0            10.1.3.3             Serial0/1/1

0.0.0.0/8            drop

0.0.0.0/32           receive

10.1.3.0/24          attached             Serial0/1/1

10.1.3.0/32          receive              Serial0/1/1

10.1.3.1/32          receive              Serial0/1/1

10.1.3.3/32          10.1.3.3             Serial0/1/1

10.1.3.255/32        receive              Serial0/1/1

10.1.13.0/24         attached             GigabitEthernet0/0/1

10.1.13.0/32         receive              GigabitEthernet0/0/1

10.1.13.1/32         receive              GigabitEthernet0/0/1

10.1.13.13/32        attached             GigabitEthernet0/0/1

10.1.13.255/32       receive              GigabitEthernet0/0/1

10.2.0.0/16          10.1.13.13           GigabitEthernet0/0/1

127.0.0.0/8          drop

224.0.0.0/4          drop

224.0.0.0/24         receive

240.0.0.0/4          drop

255.255.255.255/32   receive

  1. Issue the command show adjacency, which shows you the address neighbors on each interface.

R1# show adjacency

Protocol Interface                 Address

IP       GigabitEthernet0/0/1      10.1.13.13(11)

IP       GigabitEthernet0/0/1      227.0.0.0(3)

IPV6     GigabitEthernet0/0/1      2001:DB8:ACAD:10D1::D1(12)

IPV6     GigabitEthernet0/0/1      FE80::D1:1(3)

IPV6     GigabitEthernet0/0/1      FFFF::(3)

IP       Serial0/1/1               point2point(13)

IPV6     Serial0/1/1               point2point(13)

  1. Expand this a bit and issue the command show adjacency detail, and you will see that the router has precompiled the Layer 2 headers and other details to allow it to package information quickly.

R1# show adjacency detail

Protocol Interface                 Address

IP       GigabitEthernet0/0/1      10.1.13.13(11)

                                   20 packets, 1680 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 14

                                   001AE3CFB8C37079B39236410800

                                   L2 destination address byte offset 0

                                   L2 destination address byte length 6

                                   Link-type after encap: ip

                                   ARP

IP       GigabitEthernet0/0/1      227.0.0.0(3)

                                   connectionid 1

                                   0 packets, 0 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 14

                                   01005E0000007079B39236410800

                                   L2 destination address byte offset 0

                                   L2 destination address byte length 6

                                   Link-type after encap: ip

                                   Inject p2mp Multicast

IPV6     GigabitEthernet0/0/1      2001:DB8:ACAD:10D1::D1(12)

                                   5 packets, 570 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 14

                                   001AE3CFB8C37079B392364186DD

                                   L2 destination address byte offset 0

                                   L2 destination address byte length 6

                                   Link-type after encap: ipv6

                                   IPv6 ND

IPV6     GigabitEthernet0/0/1      FE80::D1:1(3)

                                   0 packets, 0 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 14

                                   001AE3CFB8C37079B392364186DD

                                   L2 destination address byte offset 0

                                   L2 destination address byte length 6

                                   Link-type after encap: ipv6

                                   IPv6 ND

IPV6     GigabitEthernet0/0/1      FFFF::(3)

                                   connectionid 1

                                   8 packets, 720 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 14

                                   3333000000007079B392364186DD

                                   L2 destination address byte offset 0

                                   L2 destination address byte length 6

                                   Link-type after encap: ipv6

                                   Inject p2mp Multicast

IP       Serial0/1/1               point2point(13)

                                   8 packets, 512 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 4

                                   0F000800

                                   P2P-ADJ

IPV6     Serial0/1/1               point2point(13)

                                   18599 packets, 1756190 bytes

                                   epoch 0

                                   sourced in sev-epoch 0

                                   Encap length 4

                                   0F0086DD

                                   P2P-ADJ

Close configuration window

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Device Configs – Final

Router R1

R1# show run

Building configuration…

 

Current configuration : 1601 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

ipv6 unicast-routing

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

 mode none

!

interface GigabitEthernet0/0/0

 no ip address

 negotiation auto

!

interface GigabitEthernet0/0/1

 ip address 10.1.13.1 255.255.255.0

 negotiation auto

 ipv6 address FE80::1:1 link-local

 ipv6 address 2001:DB8:ACAD:10D1::1/64

!

interface Serial0/1/0

 no ip address

!

interface Serial0/1/1

 ip address 10.1.3.1 255.255.255.0

 ipv6 address FE80::1:2 link-local

 ipv6 address 2001:DB8:ACAD:1013::1/64

!

ip forward-protocol nd

no ip http server

ip http secure-server

ip route 0.0.0.0 0.0.0.0 10.1.3.3

ip route 10.2.0.0 255.255.0.0 10.1.13.13

!

ipv6 route 2001:DB8:ACAD:1050::/64 2001:DB8:ACAD:10D1::D1

ipv6 route 2001:DB8:ACAD:1060::/64 2001:DB8:ACAD:10D1::D1

ipv6 route ::/0 2001:DB8:ACAD:1013::3

!

control-plane

!

banner motd ^C This is R1, Inter-VLAN Routing Lab ^C

!

line con 0

 exec-timeout 0 0

 logging synchronous

 transport input none

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 login

!

end

Router R3

R3# show run

Building configuration…

 

Current configuration : 1790 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R3

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

ipv6 unicast-routing

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

 mode none

!

interface GigabitEthernet0/0/0

 no ip address

 negotiation auto

!

interface GigabitEthernet0/0/1

 no ip address

 negotiation auto

!

interface GigabitEthernet0/0/1.75

 encapsulation dot1Q 75

 ip address 10.3.75.1 255.255.255.0

 ipv6 address FE80::3:2 link-local

 ipv6 address 2001:DB8:ACAD:3075::1/64

!

interface GigabitEthernet0/0/1.85

 encapsulation dot1Q 85

 ip address 10.3.85.1 255.255.255.0

 ipv6 address FE80::3:3 link-local

 ipv6 address 2001:DB8:ACAD:3085::1/64

!

interface GigabitEthernet0/0/1.999

 encapsulation dot1Q 999 native

!

interface Serial0/1/0

 no ip address

!

interface Serial0/1/1

 ip address 10.1.3.3 255.255.255.0

 ipv6 address FE80::3:1 link-local

 ipv6 address 2001:DB8:ACAD:1013::3/64

!

ip forward-protocol nd

no ip http server

ip http secure-server

ip route 0.0.0.0 0.0.0.0 10.1.3.1

!

ipv6 route ::/0 2001:DB8:ACAD:1013::1

!

control-plane

!

banner motd ^C This is R3, Inter-VLAN Routing Lab ^C

!

line con 0

 exec-timeout 0 0

 logging synchronous

 transport input none

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 login

!

end

Switch D1

D1# show run

Building configuration…

 

Current configuration : 9334 bytes

!

version 16.9

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

! Call-home is enabled by Smart-Licensing.

service call-home

no platform punt-keepalive disable-kernel-core

!

hostname D1

!

!

vrf definition Mgmt-vrf

 !

 address-family ipv4

 exit-address-family

 !

 address-family ipv6

 exit-address-family

!

!

no aaa new-model

switch 1 provision ws-c3650-24ts

!

ip routing

!

no ip domain lookup

!

login on-success log

 

ipv6 unicast-routing

!

license boot level ipservicesk9

!

diagnostic bootup level minimal

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

redundancy

 mode sso

!

transceiver type all

 monitoring

!

class-map match-any system-cpp-police-topology-control

  description Topology control

class-map match-any system-cpp-police-sw-forward

  description Sw forwarding, L2 LVX data, LOGGING

class-map match-any system-cpp-default

  description Inter FED, EWLC control, EWLC data

class-map match-any system-cpp-police-sys-data

  description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed

class-map match-any system-cpp-police-punt-webauth

  description Punt Webauth

class-map match-any system-cpp-police-l2lvx-control

  description L2 LVX control packets

class-map match-any system-cpp-police-forus

  description Forus Address resolution and Forus traffic

class-map match-any system-cpp-police-multicast-end-station

  description MCAST END STATION

class-map match-any system-cpp-police-multicast

  description Transit Traffic and MCAST Data

class-map match-any system-cpp-police-l2-control

  description L2 control

class-map match-any system-cpp-police-dot1x-auth

  description DOT1X Auth

class-map match-any system-cpp-police-data

  description ICMP redirect, ICMP_GEN and BROADCAST

class-map match-any system-cpp-police-stackwise-virt-control

  description Stackwise Virtual

class-map match-any non-client-nrt-class

class-map match-any system-cpp-police-routing-control

  description Routing control and Low Latency

class-map match-any system-cpp-police-protocol-snooping

  description Protocol snooping

class-map match-any system-cpp-police-dhcp-snooping

  description DHCP snooping

class-map match-any system-cpp-police-system-critical

  description System Critical and Gold Pkt

!

policy-map system-cpp-policy

!

!

interface GigabitEthernet0/0

 vrf forwarding Mgmt-vrf

 no ip address

 shutdown

 negotiation auto

!

interface GigabitEthernet1/0/1

 shutdown

!

interface GigabitEthernet1/0/2

 shutdown

!

interface GigabitEthernet1/0/3

 shutdown

!

interface GigabitEthernet1/0/4

 shutdown

!

interface GigabitEthernet1/0/5

 shutdown

!

interface GigabitEthernet1/0/6

 shutdown

!

interface GigabitEthernet1/0/7

 shutdown

!

interface GigabitEthernet1/0/8

 shutdown

!

interface GigabitEthernet1/0/9

 shutdown

!

interface GigabitEthernet1/0/10

 shutdown

!

interface GigabitEthernet1/0/11

 no switchport

 ip address 10.1.13.13 255.255.255.0

 ipv6 address FE80::D1:1 link-local

 ipv6 address 2001:DB8:ACAD:10D1::D1/64

!

interface GigabitEthernet1/0/12

 shutdown

!

interface GigabitEthernet1/0/13

 shutdown

!

interface GigabitEthernet1/0/14

 shutdown

!

interface GigabitEthernet1/0/15

 shutdown

!

interface GigabitEthernet1/0/16

 shutdown

!

interface GigabitEthernet1/0/17

 shutdown

!

interface GigabitEthernet1/0/18

 shutdown

!

interface GigabitEthernet1/0/19

 shutdown

!

interface GigabitEthernet1/0/20

 shutdown

!

interface GigabitEthernet1/0/21

 shutdown

!

interface GigabitEthernet1/0/22

 shutdown

!

interface GigabitEthernet1/0/23

 switchport access vlan 50

 switchport mode access

!

interface GigabitEthernet1/0/24

 switchport access vlan 60

 switchport mode access

!

interface GigabitEthernet1/1/1

 shutdown

!

interface GigabitEthernet1/1/2

 shutdown

!

interface GigabitEthernet1/1/3

 shutdown

!

interface GigabitEthernet1/1/4

 shutdown

!

interface Vlan1

 no ip address

 shutdown

!

interface Vlan50

 ip address 10.2.50.1 255.255.255.0

 ipv6 address FE80::D1:2 link-local

 ipv6 address 2001:DB8:ACAD:1050::D1/64

!

interface Vlan60

 ip address 10.2.60.1 255.255.255.0

 ipv6 address FE80::D1:3 link-local

 ipv6 address 2001:DB8:ACAD:1060::D1/64

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip route 0.0.0.0 0.0.0.0 10.1.13.1

!

!

ipv6 route ::/0 2001:DB8:ACAD:10D1::1

!

!

control-plane

 service-policy input system-cpp-policy

!

banner motd ^C This is D1, Inter-VLAN Routing Lab ^C

!

line con 0

 exec-timeout 0 0

 logging synchronous

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 login

line vty 5 15

 login

!

end

Switch D2

D2# show run

Building configuration…

 

Current configuration : 9069 bytes

!

version 16.9

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

! Call-home is enabled by Smart-Licensing.

service call-home

no platform punt-keepalive disable-kernel-core

!

hostname D2

!

!

vrf definition Mgmt-vrf

 !

 address-family ipv4

 exit-address-family

 !

 address-family ipv6

 exit-address-family

!

no aaa new-model

switch 1 provision ws-c3650-24ts

!

no ip domain lookup

!

login on-success log

!

license boot level ipservicesk9

!

diagnostic bootup level minimal

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

redundancy

 mode sso

!

transceiver type all

 monitoring

!

class-map match-any system-cpp-police-topology-control

  description Topology control

class-map match-any system-cpp-police-sw-forward

  description Sw forwarding, L2 LVX data, LOGGING

class-map match-any system-cpp-default

  description Inter FED, EWLC control, EWLC data

class-map match-any system-cpp-police-sys-data

  description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed

class-map match-any system-cpp-police-punt-webauth

  description Punt Webauth

class-map match-any system-cpp-police-l2lvx-control

  description L2 LVX control packets

class-map match-any system-cpp-police-forus

  description Forus Address resolution and Forus traffic

class-map match-any system-cpp-police-multicast-end-station

  description MCAST END STATION

class-map match-any system-cpp-police-multicast

  description Transit Traffic and MCAST Data

class-map match-any system-cpp-police-l2-control

  description L2 control

class-map match-any system-cpp-police-dot1x-auth

  description DOT1X Auth

class-map match-any system-cpp-police-data

  description ICMP redirect, ICMP_GEN and BROADCAST

class-map match-any system-cpp-police-stackwise-virt-control

  description Stackwise Virtual

class-map match-any non-client-nrt-class

class-map match-any system-cpp-police-routing-control

  description Routing control and Low Latency

class-map match-any system-cpp-police-protocol-snooping

  description Protocol snooping

class-map match-any system-cpp-police-dhcp-snooping

  description DHCP snooping

class-map match-any system-cpp-police-system-critical

  description System Critical and Gold Pkt

!

policy-map system-cpp-policy

!

interface GigabitEthernet0/0

 vrf forwarding Mgmt-vrf

 no ip address

 shutdown

 negotiation auto

!

interface GigabitEthernet1/0/1

 shutdown

!

interface GigabitEthernet1/0/2

 shutdown

!

interface GigabitEthernet1/0/3

 shutdown

!

interface GigabitEthernet1/0/4

 shutdown

!

interface GigabitEthernet1/0/5

 shutdown

!

interface GigabitEthernet1/0/6

 shutdown

!

interface GigabitEthernet1/0/7

 shutdown

!

interface GigabitEthernet1/0/8

 shutdown

!

interface GigabitEthernet1/0/9

 shutdown

!

interface GigabitEthernet1/0/10

 shutdown

!

interface GigabitEthernet1/0/11

 switchport trunk native vlan 999

 switchport trunk allowed vlan 75,85,999

 switchport mode trunk

!

interface GigabitEthernet1/0/12

 shutdown

!

interface GigabitEthernet1/0/13

 shutdown

!

interface GigabitEthernet1/0/14

 shutdown

!

interface GigabitEthernet1/0/15

 shutdown

!

interface GigabitEthernet1/0/16

 shutdown

!

interface GigabitEthernet1/0/17

 shutdown

!

interface GigabitEthernet1/0/18

 shutdown

!

interface GigabitEthernet1/0/19

 shutdown

!

interface GigabitEthernet1/0/20

 shutdown

!

interface GigabitEthernet1/0/21

 shutdown

!

interface GigabitEthernet1/0/22

 shutdown

!

interface GigabitEthernet1/0/23

 switchport access vlan 75

 switchport mode access

!

interface GigabitEthernet1/0/24

 switchport access vlan 85

 switchport mode access

!

interface GigabitEthernet1/1/1

 shutdown

!

interface GigabitEthernet1/1/2

 shutdown

!

interface GigabitEthernet1/1/3

 shutdown

!

interface GigabitEthernet1/1/4

 shutdown

!

interface Vlan1

 no ip address

 shutdown

!

interface Vlan75

 ip address 10.3.75.14 255.255.255.0

 ipv6 address FE80::D2:1 link-local

 ipv6 address 2001:DB8:ACAD:3075::D2/64

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

control-plane

 service-policy input system-cpp-policy

!

banner motd ^C This is D2, Inter-VLAN Routing Lab ^C

!

line con 0

 exec-timeout 0 0

 logging synchronous

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 login

line vty 5 15

 login

!

end

Subscribe
Notify of
guest
0 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments