• Post author:
  • Post category:Blog
  • Reading time:248 mins read
  • Post last modified:June 12, 2024

7.1.2 Lab – Implement Multi-Area OSPFv2 Answers

Lab – Implement Multi-Area OSPFv2 (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

The topology has 3 routers, 2 switches and 2 PCs. PC1 is connected to D1 G1/0/23. D1 G1/0/5 is connected R1 to G0/0/1. R1 G0/0/0 is connected to R2 G0/0/0. R2 G0/0/1 is connected to R3 G0/0/0. R3 G0/0/1 is connected to D2 G1/0/11. D2 G1/0/23 is connected to PC3.

Addressing Table

Device

Interface

IPv4 Address

R1

G0/0/0

172.16.0.2/30

R1

G0/0/1

10.10.0.1/30

R2

Lo0

209.165.200.225/27

R2

G0/0/0

172.16.0.1/30

R2

G0/0/1

172.16.1.1/30

R3

G0/0/0

172.16.1.2/30

R3

G0/0/1

10.10.4.1/30

D1

G1/0/11

10.10.0.2/30

D1

G1/0/23

10.10.1.1/24

D2

G1/0/11

10.10.4.2/30

D2

G1/0/23

10.10.5.1/24

PC1

NIC

10.10.1.10/24

PC2

NIC

10.10.5.10/24

Objectives

Part 1: Build the Network and Configure Basic Device Settings and Interface Addressing

Part 2: Configure and Verify Multiarea OSPF for IPv4 on R1, D1, and D2

Part 3: Exploring Link State Announcements

Background / Scenario

To make OSPF more efficient and scalable, OSPF supports hierarchical routing using the areas. An OSPF area is a group of routers that share the same link-state information in their link-state databases (LSDBs). When a large OSPF area is divided into smaller areas, it is called multiarea OSPF. Multi-area OSPF is useful in larger network deployments to reduce processing and memory overhead.

In this lab you will configure multiarea OSPF version 2 for IPv4. This lab was specifically designed to use three routers and two Layer 3 switches.

Note: This lab is an exercise in developing, deploying, and verifying how multiarea OSPF operates and does not reflect networking best practices.

Note: The routers used with this CCNP hands-on lab is a Cisco 4221and the two Layer 3 switches are Catalyst 3560 switches. Other routers and Layer 3 switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs.

Note: Ensure that the routers and switches have been erased and have no startup configurations. If you are unsure contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3650 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 PCs (Windows with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1:Build the Network and Configure Basic Device Settings and Interface Addressing

In Part 1, you will set up the network topology and configure basic settings and interface addressing on the routers and Layer 3 switches.

Step 1:Cable the network as shown in the topology.

Attach the devices as shown in the topology diagram, and cable as necessary.

Step 2:Configure basic settings for the routers and switches.

  1. Console into each router and Layer 3 switch, enter global configuration mode, and apply the basic settings and interface addressing using the following startup configurations for each device.

Open configuration window

Router R1

hostname R1

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R1, Implement Multi-Area OSPFv2 Lab #

interface g0/0/0

ip add 172.16.0.2 255.255.255.252

no shut

exit

interface GigabitEthernet0/0/1

ip address 10.10.0.1 255.255.255.252

no shut

exit

Router R2

hostname R2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R2, Implement Multi-Area OSPFv2 Lab #

interface g0/0/0

ip add 172.16.0.1 255.255.255.252

no shut

exit

interface GigabitEthernet0/0/1

ip address 172.16.1.1 255.255.255.252

no shut

exit

interface lo0

ip add 209.165.200.225 255.255.255.224

exit

Router R3

hostname R3

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is R3, Implement Multi-Area OSPFv2 Lab #

interface g0/0/0

ip add 172.16.1.2 255.255.255.252

no shut

exit

interface GigabitEthernet0/0/1

ip address 10.10.4.1 255.255.255.252

no shut

exit

Switch D1

hostname D1

no ip domain lookup

line con 0

exec-timeout 0 0

logging synchronous

exit

banner motd # This is D1, Implement Multi-Area OSPFv2 Lab #

interface g1/0/11

no switchport

ip address 10.10.0.2 255.255.255.252

no shut

exit

interface g1/0/23

no switchport

ip address 10.10.1.1 255.255.255.0

no shut

exit

Switch D2

hostname D2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

banner motd # This is D2, Implement Multi-Area OSPFv2 Lab #

interface g1/0/11

no switchport

ip address 10.10.4.2 255.255.255.252

no shut

exit

interface g1/0/23

no switchport

ip address 10.10.5.1 255.255.255.0

no shut

exit

  1. Save the running configuration to startup-config.
  2. Verify the interface status using the show ip interface brief command.

R1# show ip interface brief | include manual

GigabitEthernet0/0/0172.16.0.2YES manual upup

GigabitEthernet0/0/110.10.0.1YES manual upup

R2# show ip interface brief | include manual

GigabitEthernet0/0/0172.16.0.1YES manual upup

GigabitEthernet0/0/1172.16.1.1YES manual upup

Loopback0209.165.200.225 YES manual upup

R3# show ip interface brief | include manual

GigabitEthernet0/0/0172.16.1.2YES manual upup

GigabitEthernet0/0/110.10.4.1YES manual upup

D1# show ip interface brief | include manual

GigabitEthernet1/0/1110.10.0.2YES manual upup

GigabitEthernet1/0/2310.10.1.1YES manual upup

D2# show ip interface brief | include manual

GigabitEthernet1/0/1110.10.4.2YES manual upup

GigabitEthernet1/0/2310.10.5.1YES manual upup

  1. Verify direct connectivity between all five devices. R1 is shown as an example.

R1# ping 10.10.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.0.2, timeout is 2 seconds:

..!!!

Success rate is 60 percent (3/5), round-trip min/avg/max = 2/2/2 ms

R1# ping 172.16.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

All five devices should be able to reach the other directly connected networks. Troubleshoot if necessary.

Close configuration window

Part 2:Configure Multiarea OSPFv2

In this part, you will implement multiarea OSPF. Multiarea OSPF defines a two-layer area hierarchy using a backbone area interconnecting regular areas. This is useful in larger network deployments to reduce processing and memory overhead.

In this topology, OSPF has the following three areas defined:

  • Area 0 – The backbone area. All regular areas should connect to the backbone area.
  • Area 1 and Area 2 – Regular OSPF areas that connect to the backbone area.

The routers and switches in the topology are used in the following roles:

  • Internal routers – R2 is an internal router in Area 0, D1 is internal in Area 1, and D2 is internal in Area 2.
  • Backbone routers – R1, R2, and R3 are backbone routers as they all have interfaces in Area 0.
  • Area Border routers (ABRs) – R1 and R3 are ABRs because they connect regular areas (i.e., Area 1 and Area 2) to the backbone Area 0.
  • Autonomous System Boundary router (ASBR) – R2 is an ASBR because it connects to another non-OSPF network.

Recall that OSPF can be enabled using the traditional network router configuration command or by using the ip ospf process-id area area-id interface configuration command. Although the interface method is simpler, the OSPF routing configuration commands are applied to individual interfaces and not conveniently found in a central location. Therefore, in this lab, we will implement multiarea OSPF using wildcard masks.

You will now configure multiarea OSPF on all five devices starting with D1. You will also configure router IDs, reference bandwidths, and default route propagation.

Note: The verification output displayed in the following part assumes that the devices have been configured in the prescribed order. The output will vary if all devices are configured simultaneously.

Step 1:Implement OSPF on D1 using wildcard masks.

D1 will advertise its OSPF networks using the network router configuration command and wildcard masks. D1 is an internal router in Area 1. Therefore, both network commands will be configured for Area 1.

  1. Layer 3 switches are not enabled to perform routing by default. Therefore, routing must be enabled using the ip routing global configuration command.

Open configuration window

D1(config)# ip routing

  1. Next, enter the OSPF router configuration mode using process ID 123, assign D1 the router ID 1.1.1.2. You will also set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet interfaces. Changing the reference bandwidth to a higher value allows for a differentiation of cost between higher-speed interfaces.

D1(config)# router ospf 123

D1(config-router)# router-id 1.1.1.2

D1(config-router)# auto-cost reference-bandwidth 1000

% OSPF: Reference bandwidth is changed.

Please ensure reference bandwidth is consistent across all routers.

Note: Setting the reference cost value too high may cause issues with low-bandwidth interfaces.

  1. Configure D1 to advertise the FastEthernet 0/5 interface 10.10.0.0/30 network in OSPF Area 1. The wildcard mask can be calculated by deducting the subnet mask (i.e., /30 = 255.255.255.252) from 255.255.255.255, resulting in a wildcard mask of 0.0.0.3.

D1(config-router)# network 10.10.0.0 0.0.0.3 area 1

  1. Next, configure D1 to advertise its Fa0/23 interface 10.10.1.0/24 network in OSPF Area 1 and return to privileged EXEC mode.

D1(config-router)# network 10.10.1.0 0.0.0.255 area 1

D1(config-router)# end

  1. Verify the OSPF configuration on D1 using the show ip protocols command.

D1# show ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is “ospf 123″

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 1.1.1.2

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

10.10.0.0 0.0.0.3 area 1

10.10.1.0 0.0.0.255 area 1

Routing Information Sources:

GatewayDistanceLast Update

Distance: (default is 110)

The output confirms the router ID, and the number of areas, and the networks advertised. Notice there are no Routing Information Sources because there are no OSPF neighbors.

  1. Verify the OSPF interfaces using the show ip ospf interface brief command.

D1# show ip ospf interface brief

InterfacePIDAreaIP Address/MaskCostState Nbrs F/C

Gi1/0/23123110.10.1.1/2410DR0/0

Gi1/0/11 123110.10.0.2/3010DR0/0

The output confirms that both G1/0/11 and G1/0/23 interfaces were correctly assigned to Area 1.

  1. Finally, verify the OSPF routes in the routing table using the show ip route ospf command.

D1# show ip route ospf

Close configuration window

Notice that no routes are displayed. This is because D1 does not yet have an OSPF neighbor.

Step 2:Implement OSPF on R1.

Next, configure R1. R1 is an ABR with an interface in Area 1 and the other interface in the backbone.

  1. Enter the OSPF router configuration mode using process ID 123, assign R1 the router ID 1.1.1.1, and set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet interfaces.

Open configuration window

R1(config)# router ospf 123

R1(config-router)# router-id 1.1.1.1

R1(config-router)# auto-cost reference-bandwidth 1000

% OSPF: Reference bandwidth is changed.

Please ensure reference bandwidth is consistent across all routers.

  1. Configure R1 to advertise the G0/0/0 interface 172.16.0.0/30 network in OSPF Area 0.

R1(config-router)# network 172.16.0.0 0.0.0.3 area 0

  1. Advertise the G0/0/1 interface 10.10.0.0/30 network in OSPF Area 1 and return to privileged EXEC mode.

R1(config-router)# network 10.10.0.0 0.0.0.3 area 1

R1(config-router)# end

*Jan4 11:55:32.064: %OSPF-5-ADJCHG: Process 123, Nbr 1.1.1.2 on GigabitEthernet0/0/1 from LOADING to FULL, Loading Done

Notice the informational message stating that a neighbor adjacency has been established with D1 (i.e., 1.1.1.2).

  1. Verify the OSPF configuration on R1 using the show ip protocols command.

R1# show ip protocols | begin ospf

Routing Protocol is “ospf 123″

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 1.1.1.1

It is an area border router

Number of areas in this router is 2. 2 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

10.10.0.0 0.0.0.3 area 1

172.16.0.0 0.0.0.3 area 0

Routing Information Sources:

GatewayDistanceLast Update

1.1.1.211000:07:55

Distance: (default is 110)

Like the previous output of D1, this output confirms the router ID, and the networks advertised. However, notice that it also explicitly states that R1 is an area border router (ABR), that it is in two areas, and that it has established an adjacency and exchanged routing information with D2 (i.e., 1.1.1.2).

  1. Verify that the reference bandwidth has been changed using the show ip ospf| begin Ref command.

R1# show ip ospf | begin Ref

Reference bandwidth unit is 1000 mbps

Area BACKBONE(0) (Inactive)

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm last executed 00:14:41.606 ago

SPF algorithm executed 2 times

Area ranges are

Number of LSA 3. Checksum Sum 0x01ABED

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

Area 1

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm last executed 00:15:07.141 ago

SPF algorithm executed 5 times

Area ranges are

Number of LSA 4. Checksum Sum 0x0292B8

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

The output confirms that the reference bandwidth has been changed to distinguish GigabitEthernet interfaces. The output also confirms that R1 is in two areas and has two link-state databases (LSDBs).

Note: Area 0 is currently inactive because there are no other peers configured yet.

  1. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.

R1# show ip ospf interface brief

InterfacePIDAreaIP Address/MaskCostState Nbrs F/C

Gi0/0/01230172.16.0.2/301DR0/0

Gi0/0/1123110.10.0.1/301 BDR1/1

The output confirms the interfaces, areas, and IP addresses.

  1. Verify which OSPF neighbors R1 has established an adjacency with using the show ip ospf neighbor command.

R1# show ip ospf neighbor

Neighbor IDPriStateDead TimeAddressInterface

1.1.1.21FULL/DR00:00:3110.10.0.2GigabitEthernet0/0/1

The output confirms that R1 has one neighbor (i.e., 1.1.1.2 = D1), they have a full adjacency established, the IP address of D1 is 10.10.0.2, and R1 can reach D1 using its G0/0/1 interface.

  1. Use the show ip ospf neighbor detail command to get additional information about neighbor adjacencies.

R1# show ip ospf neighbor detail

Neighbor 1.1.1.2, interface address 10.10.0.2, interface-id 38

In the area 1 via interface GigabitEthernet0/0/1

Neighbor priority is 1, State is FULL, 6 state changes

DR is 10.10.0.2 BDR is 10.10.0.1

Options is 0x12 in Hello (E-bit, L-bit)

Options is 0x52 in DBD (E-bit, L-bit, O-bit)

LLS Options is 0x1 (LR)

Dead timer due in 00:00:34

Neighbor is up for 00:19:09

Index 1/1/1, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

As shown, the output confirms various information about the OSPF neighbor including DR and BDR status.

  1. Verify the OSPF routes in the routing table using the show ip route ospf command.

R1# show ip route ospf | begin Gateway

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks

O10.10.1.0/24 [110/11] via 10.10.0.2, 00:24:43, GigabitEthernet0/0/1

The output displays an entry for the D1 LAN. The O designation identifies this as an OSPF internal route. Network routes learned from other OSPF routers in the same area are known as intra-area routes and are identified in the IP routing table with an O.

  1. Finally, get detailed information on how R1 learned about the OSPF entry using the show ip route ospf 10.10.1.0 command.

R1# show ip route 10.10.1.0

Routing entry for 10.10.1.0/24

Known via “ospf 123“, distance 110, metric 11, type intra area

Last update from 10.10.0.2 on GigabitEthernet0/0/1, 00:25:25 ago

Routing Descriptor Blocks:

* 10.10.0.2, from 1.1.1.2, 00:25:25 ago, via GigabitEthernet0/0/1

Route metric is 11, traffic share count is 1

The output confirms that R1 learned about the intra-area route 10.10.1.0 from 10.10.0.2 with a router ID of 1.1.1.2 in OSPF 123.

Close configuration window

Step 3:Implement OSPF on R2.

Next, configure is R2. R2 is an internal backbone router and will become an ASBR.

  1. Enter the OSPF router configuration mode using process ID 123, assign R2 the router ID 2.2.2.1, and set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet interfaces.

Open configuration window

R2(config)# router ospf 123

R2(config-router)# router-id 2.2.2.1

R2(config-router)# auto-cost reference-bandwidth 1000

% OSPF: Reference bandwidth is changed.

Please ensure reference bandwidth is consistent across all routers.

  1. Configure R2 to advertise its two interfaces in OSPF Area 0.

R2(config-router)# network 172.16.0.0 0.0.0.3 area 0

R2(config-router)# network 172.16.1.0 0.0.0.3 area 0

*Dec 28 16:22:42.530: %OSPF-5-ADJCHG: Process 123, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from LOADING to FULL, Loading Done

The output confirms that an adjacency has been established with R1 (i.e., 1.1.1.1).

Note: Alternatively, the two network statements could be combined using network 17.16.0.0 0.0.1.3 area 0.

  1. Configure R2 to propagate a default route to the internet. In our lab, the internet is represented as a loopback interface.

R2(config-router)# default-information originate

R2(config-router)# exit

R2(config)# ip route 0.0.0.0 0.0.0.0 lo0

%Default route without gateway, if not a point-to-point interface, may impact performance

R2(config)# exit

  1. Verify the OSPF configuration on R2 using the show ip protocols command.

R2# show ip protocols | begin ospf

Routing Protocol is “ospf 123″

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 2.2.2.1

It is an autonomous system boundary router

Redistributing External Routes from,

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

172.16.0.0 0.0.0.3 area 0

172.16.1.0 0.0.0.3 area 0

Routing Information Sources:

GatewayDistanceLast Update

1.1.1.111000:24:29

Distance: (default is 110)

Again, this output confirms the router ID chosen, number of areas R2 is in (i.e., 1), networks advertised, and that it has established an adjacency and exchanged routing information with R1 (i.e., 1.1.1.1). R2 does not have an adjacency with D1 because it is in another area.

Notice as well, that it explicitly states that R2 is an autonomous system boundary router (ASBR). This is because it is now propagating a default route to all other routers in the OSPF domain.

  1. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command as shown.

R2# show ip ospf | begin Ref

Reference bandwidth unit is 1000 mbps

Area BACKBONE(0)

Number of interfaces in this area is 2

Area has no authentication

SPF algorithm last executed 00:02:27.531 ago

SPF algorithm executed 5 times

Area ranges are

Number of LSA 5. Checksum Sum 0x01C25B

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

The output confirms that the reference bandwidth has been changed and also confirms that R2 has two interfaces in its link-state database (LSDB).

  1. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.

R2# show ip ospf interface brief

InterfacePIDAreaIP Address/MaskCostState Nbrs F/C

Gi0/0/11230172.16.1.1/301DR0/0

Gi0/0/01230172.16.0.1/301BDR1/1

The output confirms that the two interfaces are in Area 0, their IP addresses, state, and neighbors.

  1. Verify which OSPF neighbors R2 has established an adjacency using the show ip ospf neighbor command.

R2# show ip ospf neighbor

Neighbor IDPriStateDead TimeAddressInterface

1.1.1.11FULL/DR00:00:36172.16.0.2GigabitEthernet0/0/0

The output confirms that R2 has one neighbor (i.e., 1.1.1.1 = R1) and they have a full adjacency established.

  1. Use the show ip ospf neighbor detail command to get additional information about neighbor adjacencies.

R2# show ip ospf neigh detail

Neighbor 1.1.1.1, interface address 172.16.0.2, interface-id 5

In the area 0 via interface GigabitEthernet0/0/0

Neighbor priority is 1, State is FULL, 6 state changes

DR is 172.16.0.2 BDR is 172.16.0.1

Options is 0x12 in Hello (E-bit, L-bit)

Options is 0x52 in DBD (E-bit, L-bit, O-bit)

LLS Options is 0x1 (LR)

Dead timer due in 00:00:34

Neighbor is up for 00:27:48

Index 1/1/1, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

As shown, the output confirms various information about the OSPF neighbor including DR and BDR status.

  1. Verify the OSPF routes in the routing table using the show ip route ospf command.

R2# show ip route ospf | begin Gateway

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

O IA10.10.0.0/30 [110/2] via 172.16.0.2, 00:28:19, GigabitEthernet0/0/0

O IA10.10.1.0/24 [110/12] via 172.16.0.2, 00:28:19, GigabitEthernet0/0/0

The output displays that there is now a default gateway and two entries for the OSPF Area 1 networks. Notice how these routes are identified as O IA which means they are routes from another area. Network routes learned from OSPF routers in another area using an ABR are known as interarea routes as opposed to intra-area routes.

  1. Verify the static route entry in the routing table.

R2# show ip route static | begin Gateway

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*0.0.0.0/0 is directly connected, Loopback0

  1. Finally, get detailed information on how R2 learned about the OSPF entry using the show ip route ospf 10.10.1.0 command.

R2# show ip route 10.10.1.0

Routing entry for 10.10.1.0/24

Known via “ospf 123″, distance 110, metric 12, type inter area

Last update from 172.16.0.2 on GigabitEthernet0/0/0, 00:31:08 ago

Routing Descriptor Blocks:

* 172.16.0.2, from 1.1.1.1, 00:31:08 ago, via GigabitEthernet0/0/0

Route metric is 12, traffic share count is 1

The output confirms that R2 learned about the interarea route 10.10.1.0 from OSPF 123 and specifically from R1, based on the router ID of 1.1.1.1.

Close configuration window

Step 4:Implement OSPF on R3.

Next to configure is R3. Like R1, R3 is an ABR with an interface in Area 0 and one in Area 2.

  1. Enter the OSPF router configuration mode using process ID 123, assign R3 the router ID 3.3.3.1, and set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet interfaces.

Open configuration window

R3(config)# router ospf 123

R3(config-router)# router-id 3.3.3.1

R3(config-router)# auto-cost reference-bandwidth 1000

% OSPF: Reference bandwidth is changed.

Note: Please ensure reference bandwidth is consistent across all routers.

  1. Configure R3 to advertise its interfaces in OSPF Area 0 and Area 2 accordingly and then return to privileged EXEC mode.

R3(config-router)# network 172.16.1.0 0.0.0.3 area 0

R3(config-router)# network 10.10.4.0 0.0.0.3 area 2

R3(config-router)# end

R3#

*Jan5 19:28:25.146: %OSPF-5-ADJCHG: Process 123, Nbr 2.2.2.1 on GigabitEthernet0/0/0 from LOADING to FULL, Loading Done

  1. Verify the OSPF configuration on R3 using the show ip protocols command.

R3# show ip protocols | begin ospf

Routing Protocol is “ospf 123″

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 3.3.3.1

It is an area border router

Number of areas in this router is 2. 2 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

10.10.4.0 0.0.0.3 area 2

172.16.1.0 0.0.0.3 area 0

Routing Information Sources:

GatewayDistanceLast Update

1.1.1.111000:01:43

2.2.2.111000:01:43

Distance: (default is 110)

The output confirms the router ID, and that R3 is an ABR, it has interfaces in two areas, the networks it is advertising, and that R3 has R1 (i.e., 1.1.1.1) and R2 (i.e., 2.2.2.1) as sources of routing information.

  1. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command as shown.

R3# show ip ospf | begin Ref

Reference bandwidth unit is 1000 mbps

Area BACKBONE(0)

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm last executed 00:10:38.256 ago

SPF algorithm executed 4 times

Area ranges are

Number of LSA 8. Checksum Sum 0x0396BA

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

Area 2

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm last executed 00:10:13.755 ago

SPF algorithm executed 2 times

Area ranges are

Number of LSA 6. Checksum Sum 0x0362CF

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

The output confirms that the reference bandwidth has been changed and also confirms that R2 has area information for Area 0 and Area 2.

  1. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.

R3# show ip ospf interface brief

InterfacePIDAreaIP Address/MaskCostState Nbrs F/C

Gi0/0/01230172.16.1.2/301BDR1/1

Gi0/0/1123210.10.4.1/301 DR0/0

The output confirms the interfaces, process ID, areas, IP addresses, cost, state, and neighbors.

  1. Verify which OSPF neighbors R2 has established an adjacency with using the show ip ospf neighbor command.

R3# show ip ospf neighbor

Neighbor IDPriStateDead TimeAddressInterface

2.2.2.11FULL/DR00:00:31172.16.1.1GigabitEthernet0/0/0

The output confirms that R3 has one neighbor (i.e., 2.2.2.1= R2) and they have a full adjacency established.

  1. Use the show ip ospf neighbor detail command to get additional information about neighbor adjacencies.

R3# show ip ospf neighbor detail

Neighbor 2.2.2.1, interface address 172.16.1.1, interface-id 6

In the area 0 via interface GigabitEthernet0/0/0

Neighbor priority is 1, State is FULL, 6 state changes

DR is 172.16.1.1 BDR is 172.16.1.2

Options is 0x12 in Hello (E-bit, L-bit)

Options is 0x52 in DBD (E-bit, L-bit, O-bit)

LLS Options is 0x1 (LR)

Dead timer due in 00:00:37

Neighbor is up for 00:21:50

Index 1/1/1, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

As shown, the output confirms various information about the OSPF neighbor including DR and BDR status.

  1. Verify the OSPF routes in the routing table using the show ip route ospf command.

R3# show ip route ospf | begin Gateway

Gateway of last resort is 172.16.1.1 to network 0.0.0.0

O*E20.0.0.0/0 [110/1] via 172.16.1.1, 00:26:08, GigabitEthernet0/0/0

10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

O IA10.10.0.0/30 [110/3] via 172.16.1.1, 00:26:08, GigabitEthernet0/0/0

O IA10.10.1.0/24 [110/13] via 172.16.1.1, 00:26:08, GigabitEthernet0/0/0

172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

O172.16.0.0/30 [110/2] via 172.16.1.1, 00:26:08, GigabitEthernet0/0/0

The output verifies that R3 has received a default route from R2, two interarea routes (i.e., O IA routes) and one intra-area OSPF route (i.e., O routes). The O*E2 route indicates that this is an external route that did not originate in OSPF. The asterisk identifies this as a candidate default route.

  1. Now get detailed information on how R3 learned about the O E2 and O IA routes.

R3# show ip route 0.0.0.0

Routing entry for 0.0.0.0/0, supernet

Known via “ospf 123“, distance 110, metric 1, candidate default path

Tag 123, type extern 2, forward metric 1

Last update from 172.16.1.1 on GigabitEthernet0/0/0, 00:28:41 ago

Routing Descriptor Blocks:

* 172.16.1.1, from 2.2.2.1, 00:28:41 ago, via GigabitEthernet0/0/0

Route metric is 1, traffic share count is 1

Route tag 123

R3# show ip route 10.10.1.0

Routing entry for 10.10.1.0/24

Known via “ospf 123“, distance 110, metric 13, type inter area

Last update from 172.16.1.1 on GigabitEthernet0/0/0, 00:29:10 ago

Routing Descriptor Blocks:

* 172.16.1.1, from 1.1.1.1, 00:29:10 ago, via GigabitEthernet0/0/0

Route metric is 13, traffic share count is 1

The output confirms that R3 learned about the default route from R2 (2.2.2.1) and interarea routes from R1 (1.1.1.1) via OSPF.

Close configuration window

Step 5:Implement OSPF on D2.

Last to configure is D2. Like D1, D2 is an internal router in Area 2.

  1. Layer 3 switches are not enabled to perform routing by default. Therefore, routing must be enabled using the ip routing global configuration command.

Open configuration window

D2(config)# ip routing

  1. Next, enter the OSPF router configuration mode using process ID 123, assign the D2 the router ID 3.3.3.2, and set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet interfaces.

D2(config)# router ospf 123

D2(config-router)# router-id 3.3.3.2

D2(config-router)# auto-cost reference-bandwidth 1000

% OSPF: Reference bandwidth is changed.

Please ensure reference bandwidth is consistent across all routers.

  1. Configure D2 to advertise its interfaces in OSPF Area 2 and return to privileged EXEC mode.

D2(config-router)# network 10.10.4.0 0.0.0.3 area 2

D2(config-router)# network 10.10.5.0 0.0.0.255 area 2

D2(config-router)# end

D2#

*Mar1 01:52:03.888: %OSPF-5-ADJCHG: Process 123, Nbr 3.3.3.1 on GigabitEthernet1/0/11 from LOADING to FULL, Loading Done

  1. Verify the OSPF configuration on D2 using the show ip protocols command.

D2# show ip protocols

Routing Protocol is “ospf 123″

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 3.3.3.2

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

10.10.4.0 0.0.0.3 area 2

10.10.5.0 0.0.0.255 area 2

Routing Information Sources:

GatewayDistanceLast Update

3.3.3.111000:09:35

2.2.2.111000:04:38

Distance: (default is 110)

As expected, we can verify the router ID, number of areas, networks being advertised, and routing sources. It may be surprising that R2 (i.e., 2.2.2.1) is displayed as a routing source. The reason is because it is the source of the default route.

  1. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command as shown.

D2# show ip ospf | begin Ref

Reference bandwidth unit is 1000 mbps

Area 2

Number of interfaces in this area is 2

Area has no authentication

SPF algorithm last executed 00:13:01.877 ago

SPF algorithm executed 3 times

<output omitted>

  1. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.

D2# show ip ospf interface brief

InterfacePIDAreaIP Address/MaskCostState Nbrs F/C

Gi1/0/23123210.10.5.1/2410DR0/0

G11/0/11123210.10.4.2/301 BDR1/1

The output confirms that the two interfaces are in Area 2 and their IP addresses are correct.

  1. Verify which OSPF neighbors D2 has established an adjacency with using the show ip ospf neighbor command.

D2# show ip ospf neighbor

Neighbor IDPriStateDead TimeAddressInterface

3.3.3.11FULL/BDR00:00:3310.10.4.1GigabitEthernet1/0/11

The output confirms that D2 has one neighbor (i.e., 3.3.3.1= R3) and they have a full adjacency established.

  1. Verify the OSPF routes in the routing table using the show ip route ospf | begin Gateway command.

D2# show ip route ospf | begin Gateway

Gateway of last resort is 10.10.4.1 to network 0.0.0.0

O*E20.0.0.0/0 [110/1] via 10.10.4.1, 00:09:25, Gigabitthernet1/0/11

10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks

O IA10.10.0.0/30 [110/4] via 10.10.4.1, 00:09:00, GigabitEthernet1/0/11

O IA10.10.1.0/24 [110/14] via 10.10.4.1, 00:09:00, GigabitEthernet1/0/11

172.16.0.0/30 is subnetted, 2 subnets

O IA172.16.0.0 [110/3] via 10.10.4.1, 00:09:00, GigabitEthernet1/0/11

O IA172.16.1.0 [110/2] via 10.10.4.1, 00:09:00, GigabitEthernet1/0/11

The output displays four interarea routes (i.e., O IA routes) and the OSPF external route from 2.2.2.1(R2).

D2# show ip route 0.0.0.0

Routing entry for 0.0.0.0/0, supernet

Known via “ospf 123″, distance 110, metric 1, candidate default path

Tag 123, type extern 2, forward metric 2

Last update from 10.10.4.1 on GigabitEthernet1/0/11, 00:18:31 ago

Routing Descriptor Blocks:

* 10.10.4.1, from 2.2.2.1, 00:18:31 ago, via GigabitEthernet1/0/11

Route metric is 1, traffic share count is 1

Route tag 123

As we can see, the routing source for the default route is R2 (i.e., 2.2.2.1).

Close configuration window

Step 6:Verify end-to-end connectivity.

The multiarea OSPF network is now completely configured. We now need to verify the operation of OSPF.

  1. From PC1, verify that it has been assigned the correct IP address as listed in the Addressing Table using the ipconfig Windows command.

Open configuration window

C:\Users\Student> ipconfig

Windows IP Configuration

Ethernet adapter Ethernet0:

Connection-specific DNS Suffix. :

Link-local IPv6 Address . . . . . : fe80::7853:120b:ecdf:d718%6

IPv4 Address. . . . . . . . . . . : 10.10.1.10

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 10.10.1.1

  1. Verify end-to-end connectivity by pinging PC3.

C:\Users\Student> ping 10.10.5.10

Pinging 10.10.5.10 with 32 bytes of data:

Pinging 10.10.5.10 with 32 bytes of data:

Reply from 10.10.5.10: bytes=32 time=1ms TTL=123

Reply from 10.10.5.10: bytes=32 time=1ms TTL=123

Reply from 10.10.5.10: bytes=32 time=1ms TTL=123

Reply from 10.10.5.10: bytes=32 time=1ms TTL=123

Ping statistics for 10.10.5.10:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms

  1. Verify the route taken by doing a traceroute to PC3.

C:\Users\Student> tracert 10.10.5.10

Tracing route to DESKTOP-3FR7RKA [10.10.5.10]

over a maximum of 30 hops:

11 ms1 ms1 ms10.10.1.1

2<1 ms<1 ms<1 ms10.10.0.1

31 ms<1 ms<1 ms172.16.0.1

41 ms1 ms<1 ms172.16.1.2

51 ms2 ms2 ms10.10.4.2

61 ms<1 ms<1 msDESKTOP-3RF7RKA [10.10.5.10]

Trace complete.

This confirms end-to-end connectivity.

Close configuration window

Part 3:Exploring Link State Announcements

In this part, you will verify that the network has converged and explore how link-state advertisements (LSAs) are used as the building blocks for the OSPF link-state database (LSDB).

OSPF routers create LSAs for every directly connected OSPFenabled interface. It then sends those LSAs to OSPF peers to form adjacencies. Individually, LSAs are database records providing specific OSPF network details. Combined, they describe the entire topology of an OSPF area.

OSPF routers uses six LSA types for IPv4 routing:

  • Type 1, router LSA – All OSPFenabled routers create and send type 1 LSAs. The LSAs are immediately propagated within the area. An ABR does not forward the LSA outside the area.
  • Type 2, network LSA – Only a DR generates and advertises a type 2 LSA. The type 2 network LSA lists each of the attached routers that make up the transit network, including the DR itself, and the subnet mask that is used on the link. The DR floods the LSA to all OSPF routers (i.e., 224.0.0.5) on the multiaccess network. The content of the displayed type 2 LSA describes the network segment listing the DR address, the attached routers, and the used subnet mask. This information is used by each router participating in OSPF to build the exact picture of the described multiaccess segment, which cannot be fully described with just type 1 LSAs.
  • Type 3, summary LSA – ABRs do not forward type 1 or type 2 LSAs into other areas. ABRs flood type 3 LSAs to propagate network information to other areas. Type 3 summary LSAs describe networks that are in an area to the rest of the areas in the OSPF autonomous system.
  • Type 4, ASBR summary LSAWhen there is an ASBR in the OSPF domain, it advertises itself using a special type 1 LSA. When an ABR receives this type 1 LSA, it builds a type 4 LSA to advertise the existence of the ASBR and floods it to other areas. Subsequent ABRs regenerate a type 4 LSA and flood it into their areas.
  • Type 5, AS external LSA – ASBRs generate a type 5 external LSAs to advertise external OSPF routes to the OSPF domain. Type 5 LSAs are originated by the ASBR and are flooded to the entire autonomous system.
  • Type 7, NSSA external LSA – This is a special LSA generated by a not-so-stubby (NSSA) ASBR to advertise external OSPF networks to an OSPF domain. The ABR converts the type 7 LSA to a type 5 LSA and propagates it to other areas. An NSSA network is a special-case area type used to reduce the amount of flooding, the LSDB size, and the routing table size in routers within the area.

Note: Other LSAs also exist but are out of scope of this lab.

The focus of this section will be on LSA types 1, 2, and 3 which are used to identify intra-area and interarea routes.

Step 1:Verifying OSPF and Exploring LSAs on D1.

D1 is an internal router and generates type 1 LSAs.It is also the DR on the link connecting to R1 and therefore generates type 2 LSAs.

  1. On D1, display the list of neighbors using the show ip ospf neighbors command.

Open configuration window

D1# show ip ospf neighbor

Neighbor IDPriStateDead TimeAddressInterface

1.1.1.11FULL/BDR00:00:3210.10.0.1GigabitEthernet1/0/11

The output confirms that R1 (i.e., 1.1.1.1) is a neighbor and is the BDR on the link. Therefore, D1 must be the DR.

  1. Verify the OSPF routing table using the show ip router ospf | begin Gateway command.

D1# show ip route ospf | begin Gateway

Gateway of last resort is 10.10.0.1 to network 0.0.0.0

O*E20.0.0.0/0 [110/1] via 10.10.0.1, 01:15:48, GigabitEthernet1/0/11

10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks

O IA10.10.4.0/30 [110/4] via 10.10.0.1, 00:52:50, GigabitEthernet1/0/11

O IA10.10.5.0/24 [110/14] via 10.10.0.1, 00:24:49, GigabitEthernet1/0/11

172.16.0.0/30 is subnetted, 2 subnets

O IA172.16.0.0 [110/2] via 10.10.0.1, 02:05:06, GigabitEthernet1/0/11

O IA172.16.1.0 [110/3] via 10.10.0.1, 01:18:11, GigabitEthernet1/0/11

The routing table lists the four interarea networks and one external OSPF network.

  1. D1 learned about these networks from LSAs. A router maintains a LSDB for each area it has interfaces in. Because D1 is an internal OSPF router, it will only have entries for Area 1. To display the contents of the LSDB of D1, use the show ip ospf database command.

D1# show ip ospf database

OSPF Router with ID (1.1.1.2) (Process ID 123)

Router Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum Link count

1.1.1.11.1.1.118060x80000005 0x00DC15 1

1.1.1.21.1.1.21670x80000005 0x001AA6 2

Net Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum

10.10.0.21.1.1.21670x80000003 0x00B462

Summary Net Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum

10.10.4.01.1.1.118060x80000002 0x00A86E

10.10.5.01.1.1.118070x80000002 0x0014F4

172.16.0.01.1.1.118070x80000002 0x00DBA1

172.16.1.01.1.1.118070x80000002 0x00DAA0

Summary ASB Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum

2.2.2.11.1.1.118070x80000002 0x00131C

Type-5 AS External Link States

Link IDADV RouterAgeSeq#Checksum Tag

0.0.0.02.2.2.119390x80000002 0x009F90 123

Notice how the command output is divided into the following five sections:

  • Router Link States – These are the type 1 LSAs received by D1 and they identify the routers (i.e., 1.1.1.1 = R1, 1.1.1.2 = D1) in Area 1 that sent them, and the number of links that the routers have in the area. Therefore, R1 only has one interface in Area 1 and D1 has 2 interfaces in Area 1.
  • Net Link States – These are the type 2 LSAs generated by the DR. In our example, the DR is 1.1.1.2 (i.e., D1) on the link 10.10.0.2.
  • Summary Net Link States – These are the type 3 LSAs describing remote networks (i.e., our O IA networks or interarea routes) and the router that advertised them to D1.
  • Summary ASB Link States – This is a type 4 LSA sent by the ABR (i.e., 1.1.1.1 = R1) advertising that there is an ASBR in the network (i.e., 2.2.2.1).
  • Type-5 AS External Link States – This is a type 5 LSA advertising a default route (i.e., 0.0.0.0) and the router that is advertising it (i.e., 2.2.2.1).
    1. Additional information about the Router Link States type 1 LSA can be gathered using the show ip ospf database router command.

D1# show ip ospf database router

OSPF Router with ID (1.1.1.2) (Process ID 123)

Router Link States (Area 1)

Routing Bit Set on this LSA in topology Base with MTID 0

LS age: 843

Options: (No TOS-capability, DC)

LS Type: Router Links

Link State ID: 1.1.1.1

Advertising Router: 1.1.1.1

LS Seq Number: 80000007

Checksum: 0xD817

Length: 36

Area Border Router

Number of Links: 1

Link connected to: a Transit Network

(Link ID) Designated Router address: 10.10.0.2

(Link Data) Router Interface address: 10.10.0.1

Number of TOS metrics: 0

TOS 0 Metrics: 1

LS age: 1196

Options: (No TOS-capability, DC)

LS Type: Router Links

Link State ID: 1.1.1.2

Advertising Router: 1.1.1.2

LS Seq Number: 80000006

Checksum: 0x18A7

Length: 48

Number of Links: 2

Link connected to: a Transit Network

(Link ID) Designated Router address: 10.10.0.2

(Link Data) Router Interface address: 10.10.0.2

Number of MTID metrics: 0

TOS 0 Metrics: 1

Link connected to: a Stub Network

(Link ID) Network/subnet number: 10.10.1.0

(Link Data) Network Mask: 255.255.255.0

Number of MTID metrics: 0

TOS 0 Metrics: 10

The output provides more information about the type 1 LSAs. The first router link (i.e., type 1) LSA is from R1 (i.e., 1.1.1.1). It is an ABR with only 1 link in Area 1 which is the transit network connecting to D1. The second router link portion identifies the transit network connecting to R1 and the stub network of D1 (i.e., 10.10.1.0/24).

An OSPF link can be connected to a stub, to another router (point-to-point), or to a transit network. The transit network usually describes an Ethernet segment which can include two or more routers. If the link is connected to a transit network, the LSA also includes the IP address of the DR.

  1. To learn more about type 2 network LSAs, use show ip ospf database network command.

D1# show ip ospf database network

OSPF Router with ID (1.1.1.2) (Process ID 123)

Net Link States (Area 1)

LS age: 845

Options: (No TOS-capability, DC)

LS Type: Network Links

Link State ID: 10.10.0.2 (address of Designated Router)

Advertising Router: 1.1.1.2

LS Seq Number: 80000005

Checksum: 0xB064

Length: 32

Network Mask: /30

Attached Router: 1.1.1.2

Attached Router: 1.1.1.1

The content of the type 2 LSA describes the network segment listing the DR address, the attached routers, and subnet mask using CIDR notation. This information is used by each router in the area to build the exact picture of the described multiaccess segment, which cannot be fully described with just type 1 LSAs.

  1. To learn more about type 3 summary LSAs, use show ip ospf database summary command.

D1# show ip ospf database summary

OSPF Router with ID (1.1.1.2) (Process ID 123)

Summary Net Link States (Area 1)

LS age: 987

Options: (No TOS-capability, DC, Upward)

LS Type: Summary Links(Network)

Link State ID: 10.10.4.0 (summary Network Number)

Advertising Router: 1.1.1.1

LS Seq Number: 80000005

Checksum: 0xA271

Length: 28

Network Mask: /30

MTID: 0Metric: 3

LS age: 987

Options: (No TOS-capability, DC, Upward)

LS Type: Summary Links(Network)

Link State ID: 10.10.5.0 (summary Network Number)

Advertising Router: 1.1.1.1

LS Seq Number: 80000005

Checksum: 0xEF7

Length: 28

Network Mask: /24

MTID: 0Metric: 13

LS age: 988

Options: (No TOS-capability, DC, Upward)

LS Type: Summary Links(Network)

Link State ID: 172.16.0.0 (summary Network Number)

Advertising Router: 1.1.1.1

LS Seq Number: 80000005

Checksum: 0xD5A4

Length: 28

Network Mask: /30

MTID: 0Metric: 1

LS age: 989

Options: (No TOS-capability, DC, Upward)

LS Type: Summary Links(Network)

Link State ID: 172.16.1.0 (summary Network Number)

Advertising Router: 1.1.1.1

LS Seq Number: 80000005

Checksum: 0xD4A3

Length: 28

Network Mask: /30

MTID: 0Metric: 2

The output lists four type 3 LSAs.The LSAs identify the interarea networks, which ABR advertised, and the network mask using CIDR notation.

  1. To learn more about type 4 summary LSAs, use show ip ospf database asbr-summary command.

D1# show ip ospf database asbr-summary

OSPF Router with ID (1.1.1.2) (Process ID 123)

Summary ASB Link States (Area 1)

LS age: 591

Options: (No TOS-capability, DC, Upward)

LS Type: Summary Links(AS Boundary Router)

Link State ID: 2.2.2.1 (AS Boundary Router address)

Advertising Router: 1.1.1.1

LS Seq Number: 80000006

Checksum: 0xB20

Length: 28

Network Mask: /0

MTID: 0Metric: 1

The output lists one type 4 LSA advertised by R1 identifying 2.2.2.1 as an ASBR.

  1. Finally, to learn more about type 5 AS external link LSAs, use show ip ospf database external command.

D1# show ip ospf database external

OSPF Router with ID (1.1.1.2) (Process ID 123)

Type-5 AS External Link States

LS age: 1024

Options: (No TOS-capability, DC, Upward)

LS Type: AS External Link

Link State ID: 0.0.0.0 (External Network Number )

Advertising Router: 2.2.2.1

LS Seq Number: 80000006

Checksum: 0x9794

Length: 36

Network Mask: /0

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 1

Forward Address: 0.0.0.0

External Route Tag: 123

The output lists one type 5 LSA identifying that 0.0.0.0/0 is available from 2.2.2.1 (i.e., R2).

Open configuration window

Step 2:Verifying OSPF and exploring LSAs on an ABR R1.

R1 is an ABR with interfaces in Area 1 and Area 0. Therefore, R1 will have two LSDBs.

Display the LSDB on R1.

Open configuration window

R1# show ip ospf database

OSPF Router with ID (1.1.1.1) (Process ID 123)

Router Link States (Area 0)

Link IDADV RouterAgeSeq#Checksum Link count

1.1.1.11.1.1.112500x80000009 0x001E87 1

2.2.2.12.2.2.112840x8000000C 0x00A06E 2

3.3.3.13.3.3.112200x80000008 0x00BDDA 1

Net Link States (Area 0)

Link IDADV RouterAgeSeq#Checksum

172.16.0.21.1.1.112840x80000006 0x002A3E

172.16.1.12.2.2.112840x80000006 0x0067F9

Summary Net Link States (Area 0)

Link IDADV RouterAgeSeq#Checksum

10.10.0.01.1.1.112500x80000008 0x00B462

10.10.1.01.1.1.112500x80000006 0x0024E6

10.10.4.03.3.3.112200x80000008 0x0058B4

10.10.5.03.3.3.112200x80000006 0x00C739

Router Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum Link count

1.1.1.11.1.1.112500x80000009 0x00D419 1

1.1.1.21.1.1.216320x80000008 0x0014A9 2

Net Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum

10.10.0.21.1.1.216320x80000006 0x00AE65

Summary Net Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum

10.10.4.01.1.1.112500x80000006 0x00A072

10.10.5.01.1.1.112500x80000006 0x000CF8

172.16.0.01.1.1.112500x80000006 0x00D3A5

172.16.1.01.1.1.112500x80000006 0x00D2A4

Summary ASB Link States (Area 1)

Link IDADV RouterAgeSeq#Checksum

2.2.2.11.1.1.112500x80000006 0x000B20

Type-5 AS External Link States

Link IDADV RouterAgeSeq#Checksum Tag

0.0.0.02.2.2.112840x80000006 0x009794 123

The output displays the type 1, 2, and 3 LSAs in Area 0, and then lists the type 1, 2, 3, and 4 LSAs in Area 1. The last section displays the type 5 LSAs.

To learn more about each LSA type, use the following commands:

  • show ip ospf database router
  • show ip ospf database network
  • show ip ospf database summary
  • show ip ospf database asbr-summary
  • show ip ospf database external

Close configuration window

Step 3:Verifying OSPF and exploring LSAs on the ASBR R2.

R2 is an ASBR with interfaces in Area 0 and an external non-OSPF network.

Display the LSDB on R2.

Open configuration window

R2# show ip ospf database

OSPF Router with ID (2.2.2.1) (Process ID 123)

Router Link States (Area 0)

Link IDADV RouterAgeSeq#Checksum Link count

1.1.1.11.1.1.117900x80000009 0x001E87 1

2.2.2.12.2.2.118220x8000000C 0x00A06E 2

3.3.3.13.3.3.117590x80000008 0x00BDDA 1

Net Link States (Area 0)

Link IDADV RouterAgeSeq#Checksum

172.16.0.21.1.1.118220x80000006 0x002A3E

172.16.1.12.2.2.118220x80000006 0x0067F9

Summary Net Link States (Area 0)

Link IDADV RouterAgeSeq#Checksum

10.10.0.01.1.1.117900x80000008 0x00B462

10.10.1.01.1.1.117900x80000006 0x0024E6

10.10.4.03.3.3.117590x80000008 0x0058B4

10.10.5.03.3.3.117590x80000006 0x00C739

Type-5 AS External Link States

Link IDADV RouterAgeSeq#Checksum Tag

0.0.0.02.2.2.118220x80000006 0x009794 123

The output displays the type 1, 2, 3 and 5 LSAs in Area 0. Notice that there is no type 4 LSA because R2 is the ASBR and only an ABR can generate an LSA4.

Close configuration window

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Device Configs – Final

Router R1

R1# show run

Building configuration…

Current configuration : 1360 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

multilink bundle-name authenticated

!

diagnostic bootup level minimal

!

spanning-tree extend system-id

!

redundancy

mode none

!

interface GigabitEthernet0/0/0

ip address 172.16.0.2 255.255.255.252

negotiation auto

!

interface GigabitEthernet0/0/1

ip address 10.10.0.1 255.255.255.252

negotiation auto

!

router ospf 123

router-id 1.1.1.1

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 1

network 172.16.0.0 0.0.0.3 area 0

!

ip forward-protocol nd

no ip http server

ip http secure-server

!

control-plane

!

banner motd ^CCC This is R1, Implement Multi-Area OSPFv2 Lab ^C

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

end

Router R2

R2# show run

Building configuration…

Current configuration : 1416 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R2

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

mode none

!

interface Loopback0

ip address 209.165.200.225 255.255.255.224

!

interface GigabitEthernet0/0/0

ip address 172.16.0.1 255.255.255.252

negotiation auto

!

interface GigabitEthernet0/0/1

ip address 172.16.1.1 255.255.255.252

negotiation auto

!

router ospf 123

router-id 2.2.2.1

auto-cost reference-bandwidth 1000

network 172.16.0.0 0.0.0.3 area 0

network 172.16.1.0 0.0.0.3 area 0

default-information originate

!

ip forward-protocol nd

no ip http server

ip http secure-server

ip route 0.0.0.0 0.0.0.0 Loopback0

!

control-plane

!

banner motd ^CCC This is R2, Implement Multi-Area OSPFv2 Lab ^C

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

end

Router R3

R3# show run

Building configuration…

Current configuration : 3583 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R3

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

mode none

!

interface GigabitEthernet0/0/0

ip address 172.16.1.2 255.255.255.252

negotiation auto

!

interface GigabitEthernet0/0/1

ip address 10.10.4.1 255.255.255.252

negotiation auto

!

interface Serial0/1/0

no ip address

!

interface Serial0/1/1

no ip address

!

router ospf 123

router-id 3.3.3.1

auto-cost reference-bandwidth 1000

network 10.10.4.0 0.0.0.3 area 2

network 172.16.1.0 0.0.0.3 area 0

!

ip forward-protocol nd

no ip http server

ip http secure-server

!

control-plane

!

banner motd ^CCC This is R3, Implement Multi-Area OSPFv2 Lab ^C

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

end

Switch D1

D1# show run

Building configuration…

Current configuration : 6501 bytes

!

version 16.9

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

! Call-home is enabled by Smart-Licensing.

service call-home

no platform punt-keepalive disable-kernel-core

!

hostname D1

!

vrf definition Mgmt-vrf

!

address-family ipv4

exit-address-family

!

address-family ipv6

exit-address-family

!

!

no aaa new-model

switch 1 provision ws-c3650-24ps!

!

ip routing

!

no ip domain lookup

!

login on-success log

!

license boot level ipservicesk9

!

diagnostic bootup level minimal

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

redundancy

mode sso

!

transceiver type all

monitoring

!

class-map match-any system-cpp-police-topology-control

description Topology control

class-map match-any system-cpp-police-sw-forward

description Sw forwarding, L2 LVX data, LOGGING

class-map match-any system-cpp-default

description Inter FED, EWLC control, EWLC data

class-map match-any system-cpp-police-sys-data

description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFLSAMPLED DATA, RPF Failed

class-map match-any system-cpp-police-punt-webauth

description Punt Webauth

class-map match-any system-cpp-police-l2lvx-control

description L2 LVX control packets

class-map match-any system-cpp-police-forus

description Forus Address resolution and Forus traffic

class-map match-any system-cpp-police-multicast-end-station

description MCAST END STATION

class-map match-any system-cpp-police-multicast

description Transit Traffic and MCAST Data

class-map match-any system-cpp-police-l2-control

description L2 control

class-map match-any system-cpp-police-dot1x-auth

description DOT1X Auth

class-map match-any system-cpp-police-data

description ICMP redirect, ICMP_GEN and BROADCAST

class-map match-any system-cpp-police-stackwise-virt-control

description Stackwise Virtual

class-map match-any non-client-nrt-class

class-map match-any system-cpp-police-routing-control

description Routing control and Low Latency

class-map match-any system-cpp-police-protocol-snooping

description Protocol snooping

class-map match-any system-cpp-police-dhcp-snooping

description DHCP snooping

class-map match-any system-cpp-police-system-critical

description System Critical and Gold Pkt

!

policy-map system-cpp-policy

!

interface GigabitEthernet0/0

vrf forwarding Mgmt-vrf

no ip address

negotiation auto

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

no switchport

ip address 10.10.0.2 255.255.255.252

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

no switchport

ip address 10.10.1.1 255.255.255.0

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface Vlan1

no ip address

!

router ospf 123

router-id 1.1.1.2

auto-cost reference-bandwidth 1000

network 10.10.0.0 0.0.0.3 area 1

network 10.10.1.0 0.0.0.255 area 1

!

ip forward-protocol nd

ip http server

ip http secure-server

!

control-plane

service-policy input system-cpp-policy

!

banner motd ^C This is D1, Implement Multi-Area OSPFv2 Lab ^C

!

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

Switch D2

D2# show run

Building configuration…

Current configuration : 6501 bytes

!

version 16.9

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

! Call-home is enabled by Smart-Licensing.

service call-home

no platform punt-keepalive disable-kernel-core

!

hostname D2

!

vrf definition Mgmt-vrf

!

address-family ipv4

exit-address-family

!

address-family ipv6

exit-address-family

!

no aaa new-model

switch 1 provision ws-c3650-24ps

!

ip routing

!

no ip domain lookup

!

login on-success log

!

license boot level ipservicesk9

!

!

diagnostic bootup level minimal

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

redundancy

mode sso

!

transceiver type all

monitoring

!

class-map match-any system-cpp-police-topology-control

description Topology control

class-map match-any system-cpp-police-sw-forward

description Sw forwarding, L2 LVX data, LOGGING

class-map match-any system-cpp-default

description Inter FED, EWLC control, EWLC data

class-map match-any system-cpp-police-sys-data

description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFLSAMPLED DATA, RPF Failed

class-map match-any system-cpp-police-punt-webauth

description Punt Webauth

class-map match-any system-cpp-police-l2lvx-control

description L2 LVX control packets

class-map match-any system-cpp-police-forus

description Forus Address resolution and Forus traffic

class-map match-any system-cpp-police-multicast-end-station

description MCAST END STATION

class-map match-any system-cpp-police-multicast

description Transit Traffic and MCAST Data

class-map match-any system-cpp-police-l2-control

description L2 control

class-map match-any system-cpp-police-dot1x-auth

description DOT1X Auth

class-map match-any system-cpp-police-data

description ICMP redirect, ICMP_GEN and BROADCAST

class-map match-any system-cpp-police-stackwisevirt-control

description Stackwise Virtual

class-map match-any non-client-nrt-class

class-map match-any system-cpp-police-routing-control

description Routing control and Low Latency

class-map match-any system-cpp-police-protocol-snooping

description Protocol snooping

class-map match-any system-cpp-police-dhcp-snooping

description DHCP snooping

class-map match-any system-cpp-police-system-critical

description System Critical and Gold Pkt

!

policy-map system-cpp-policy

!

interface GigabitEthernet0/0

vrf forwarding Mgmt-vrf

no ip address

negotiation auto

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

no switchport

ip address 10.10.4.2 255.255.255.252

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

no switchport

ip address 10.10.5.1 255.255.255.0

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface Vlan1

no ip address

!

router ospf 123

router-id 3.3.3.2

auto-cost reference-bandwidth 1000

network 10.10.4.0 0.0.0.3 area 2

network 10.10.5.0 0.0.0.255 area 2

!

ip forward-protocol nd

ip http server

ip http secure-server

!

control-plane

service-policy input system-cpp-policy

!

banner motd ^C This is D2, Implement Multi-Area OSPFv2 Lab ^C

!

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

Subscribe
Notify of
guest
0 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments